summaryrefslogtreecommitdiff
path: root/math/octave
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-12 12:22:50 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-12 12:22:50 +0000
commit0e802d9a36fdbb023a047df984cdc2da5ca9d2b3 (patch)
treee4a47e9cf360e57109f0ca881272257b7728567a /math/octave
parent* Migrate to gfortran. (diff)
* Migrate to gfortran.
* Bump port revision. Approved by: portmgr(kris)
Diffstat (limited to 'math/octave')
-rw-r--r--math/octave/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 5c70e710f3f7..293617d00d84 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -7,7 +7,7 @@
PORTNAME= octave
PORTVERSION= 2.1.73
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= ftp://ftp.octave.org/pub/octave/bleeding-edge/ \
ftp://ftp.eos.hokudai.ac.jp/pub/GNU/misc/octave/bleeding-edge/ \
@@ -34,7 +34,10 @@ OCTAVE_VERSION= ${PORTVERSION}
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION} GNU_HOST=${GNU_HOST}
-F77?= f77
+WANT_FORTRAN=yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \