summaryrefslogtreecommitdiff
path: root/math/octave-forge-fenv
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-06-29 12:03:07 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-06-29 12:03:07 +0000
commitad97a8683c13ea449ab6fbebd9eecfd99f587d6b (patch)
tree7615e33b857e81888a1686bbab3823252f003c55 /math/octave-forge-fenv
parentThe octave-forge package is the result of The GNU Octave Repositry Project, w... (diff)
The octave-forge package is the result of the GNU Octave Repositry project, which is intended to be a central location for custom scripts, funcitons and extensions for GNU Octave, contains the source for all the functions plus build and install scripts.
This is fenv. On supported architectures, change the rounding mode of the floating point arithmetics (to nearest, up, down, to zero) or change the precision of the test the properties of the floating point arithmetics. WWW: http://octave.sourceforge.net/ PR: ports/147601 Submitted by: Stephen Montgomery-Smith <stephen@missouri.edu> Feature safe: yes
Diffstat (limited to 'math/octave-forge-fenv')
-rw-r--r--math/octave-forge-fenv/Makefile23
-rw-r--r--math/octave-forge-fenv/distinfo3
-rw-r--r--math/octave-forge-fenv/files/patch-src_Makefile17
-rw-r--r--math/octave-forge-fenv/pkg-descr13
-rw-r--r--math/octave-forge-fenv/pkg-plist1
5 files changed, 57 insertions, 0 deletions
diff --git a/math/octave-forge-fenv/Makefile b/math/octave-forge-fenv/Makefile
new file mode 100644
index 000000000000..ff6e51337e99
--- /dev/null
+++ b/math/octave-forge-fenv/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: octave-forge-fenv
+# Date created: 6 June 2010
+# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-fenv
+PORTVERSION= 0.1.0
+CATEGORIES= math
+
+MAINTAINER= stephen@missouri.edu
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTAVE_PKGNAME}/src
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+
+post-build:
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-fenv/distinfo b/math/octave-forge-fenv/distinfo
new file mode 100644
index 000000000000..1b8100c9af19
--- /dev/null
+++ b/math/octave-forge-fenv/distinfo
@@ -0,0 +1,3 @@
+MD5 (octave-forge/fenv-0.1.0.tar.gz) = db97ef4ca12b0c5fdb36e18079926a8c
+SHA256 (octave-forge/fenv-0.1.0.tar.gz) = 85d67be250af42e8e10a7afee2018ed0ecd1e823cc28bb73286f1139fc5fcb45
+SIZE (octave-forge/fenv-0.1.0.tar.gz) = 30399
diff --git a/math/octave-forge-fenv/files/patch-src_Makefile b/math/octave-forge-fenv/files/patch-src_Makefile
new file mode 100644
index 000000000000..4c9ccd134ed0
--- /dev/null
+++ b/math/octave-forge-fenv/files/patch-src_Makefile
@@ -0,0 +1,17 @@
+--- Makefile-orig 2010-06-06 16:11:01.000000000 -0500
++++ Makefile 2010-06-06 16:11:17.000000000 -0500
+@@ -1,13 +1,10 @@
+-include configure.in # This file is automatically generated by
+- # ../pre_install.m and sets FENV_OPTS
+-
+ OCT = fe_system_dependent.oct
+ SRC := $(OCT:.oct=.cc)
+
+ all: $(OCT)
+ fe_system_dependent: $(OCT)
+
+-%.oct: %.cc configure.in Makefile
++%.oct: %.cc Makefile
+ mkoctfile -s $< $(FENV_OPTS)
+
+
diff --git a/math/octave-forge-fenv/pkg-descr b/math/octave-forge-fenv/pkg-descr
new file mode 100644
index 000000000000..2a638afb4bf7
--- /dev/null
+++ b/math/octave-forge-fenv/pkg-descr
@@ -0,0 +1,13 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is fenv.
+
+On supported architectures, change the rounding mode of the floating point
+arithmetics (to nearest, up, down, to zero) or change the precision of the
+arithmetical operations (single, double, double extended). Experimentally
+test the properties of the floating point arithmetics.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-fenv/pkg-plist b/math/octave-forge-fenv/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-fenv/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty