summaryrefslogtreecommitdiff
path: root/math/mumps
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2009-11-28 10:44:56 +0000
committerThierry Thomas <thierry@FreeBSD.org>2009-11-28 10:44:56 +0000
commit532f881192e54b6a05668cf16b6189f5bdd6b7e5 (patch)
tree98425fe5718b372e97a66d6b0f071f732e042bd3 /math/mumps
parent- Upgrade to 1.2.1 (diff)
- Chase relocation of net/mpich2
- Bump PORTREVISION if needed - Fix some portlint errors.
Diffstat (limited to 'math/mumps')
-rw-r--r--math/mumps/Makefile20
-rw-r--r--math/mumps/files/patch-Make.inc+Makefile.inc.generic4
2 files changed, 12 insertions, 12 deletions
diff --git a/math/mumps/Makefile b/math/mumps/Makefile
index 3647575bb100..5b4736b4a79b 100644
--- a/math/mumps/Makefile
+++ b/math/mumps/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mumps
PORTVERSION= 4.8.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= http://mumps.enseeiht.fr/ \
http://graal.ens-lyon.fr/MUMPS/ \
@@ -66,12 +66,12 @@ LAPACK_LIBS= -llapack
.ifdef WITH_MPI
PKGNAMESUFFIX+= -mpich
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/include/mpif.h:${PORTSDIR}/net/mpich2 \
+BUILD_DEPENDS+= ${LOCALBASE}/include/mpif.h:${PORTSDIR}/net/mpich2 \
${LOCALBASE}/lib/libblacs.a:${PORTSDIR}/math/blacs \
${LOCALBASE}/lib/libscalapack.a:${PORTSDIR}/math/scalapack
LIB_DEPENDS+= lapack:${PORTSDIR}/math/lapack
# Note: -l?mumps still requires to be linked with -lblacs + -lscalapack
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2 \
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2 \
${LOCALBASE}/lib/libblacs.a:${PORTSDIR}/math/blacs \
${LOCALBASE}/lib/libscalapack.a:${PORTSDIR}/math/scalapack
CONFLICTS= mumps-4*
@@ -142,16 +142,16 @@ regression-test:
${CHMOD} go-r ${HOME}/.mpd.conf
@${ECHO_MSG} "${HOME}/.mpd.conf has been generated - please change the secret word!"
. endif
- ${LOCALBASE}/mpich2/bin/mpd &
+ ${LOCALBASE}/bin/mpd &
(cd ${WRKSRC}/examples && \
- ${LOCALBASE}/mpich2/bin/mpirun -np 2 ./ssimpletest < input_simpletest_real ; \
- ${LOCALBASE}/mpich2/bin/mpirun -np 2 ./dsimpletest < input_simpletest_real ; \
- ${LOCALBASE}/mpich2/bin/mpirun -np 2 ./csimpletest < input_simpletest_cmplx ; \
- ${LOCALBASE}/mpich2/bin/mpirun -np 2 ./zsimpletest < input_simpletest_cmplx ; \
+ ${LOCALBASE}/bin/mpirun -np 2 ./ssimpletest < input_simpletest_real ; \
+ ${LOCALBASE}/bin/mpirun -np 2 ./dsimpletest < input_simpletest_real ; \
+ ${LOCALBASE}/bin/mpirun -np 2 ./csimpletest < input_simpletest_cmplx ; \
+ ${LOCALBASE}/bin/mpirun -np 2 ./zsimpletest < input_simpletest_cmplx ; \
${ECHO_MSG} "The solution should be (1,2,3,4,5)" ; \
- ${LOCALBASE}/mpich2/bin/mpirun -np 3 ./c_example ; \
+ ${LOCALBASE}/bin/mpirun -np 3 ./c_example ; \
${ECHO_MSG} "The solution should be (1,2)")
- ${LOCALBASE}/mpich2/bin/mpdallexit
+ ${LOCALBASE}/bin/mpdallexit
.else
(cd ${WRKSRC}/examples && \
./ssimpletest < input_simpletest_real ; \
diff --git a/math/mumps/files/patch-Make.inc+Makefile.inc.generic b/math/mumps/files/patch-Make.inc+Makefile.inc.generic
index 0381879259af..7421456b4d47 100644
--- a/math/mumps/files/patch-Make.inc+Makefile.inc.generic
+++ b/math/mumps/files/patch-Make.inc+Makefile.inc.generic
@@ -48,11 +48,11 @@
# INCLUDE DIRECTORY FOR MPI
-INCPAR = -I/usr/include
-+INCPAR = -I@LOCALBASE@/mpich2/include
++INCPAR = -I@LOCALBASE@/include
# LIBRARIES USED BY THE PARALLEL VERSION OF MUMPS: $(SCALAP) and MPI
-LIBPAR = $(SCALAP) -L/usr/lib -lmpi
-+LIBPAR = -L@LOCALBASE@/mpich2/lib -lfmpich -lmpich $(SCALAP)
++LIBPAR = -L@LOCALBASE@/lib -lfmpich -lmpich $(SCALAP)
# The parallel version is not concerned by the next two lines.
# They are related to the sequential library provided by MUMPS,