summaryrefslogtreecommitdiff
path: root/math/libqalculate/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-03 19:13:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-03 19:13:53 +0000
commitae155dfccdebcb5b66232acc0fc83ac075809765 (patch)
tree84a9e56b2446e2e987868c74a929305e30b9c6c8 /math/libqalculate/files
parentDisable the use of Jikes when using Java 1.5 because the current stable version (diff)
- Update to 0.8.2
- Fix build with latest cln Submitted by: maintainer
Diffstat (limited to 'math/libqalculate/files')
-rw-r--r--math/libqalculate/files/patch-libqalculate-Number.cc29
-rw-r--r--math/libqalculate/files/patch-src-Makefile.in11
2 files changed, 29 insertions, 11 deletions
diff --git a/math/libqalculate/files/patch-libqalculate-Number.cc b/math/libqalculate/files/patch-libqalculate-Number.cc
new file mode 100644
index 000000000000..c179a9ee8938
--- /dev/null
+++ b/math/libqalculate/files/patch-libqalculate-Number.cc
@@ -0,0 +1,29 @@
+--- libqalculate/Number.cc.orig Thu Nov 3 18:27:14 2005
++++ libqalculate/Number.cc Thu Nov 3 18:28:15 2005
+@@ -2389,7 +2389,7 @@
+ if(po.indicate_infinite_series && !infinite_series) {
+ remainders.push_back(remainder);
+ }
+- remainder *= base;
++ remainder = remainder * base;
+ div = cln::truncate2(remainder, d);
+ remainder2 = div.remainder;
+ remainder = div.quotient;
+@@ -2398,7 +2398,7 @@
+ started = !cln::zerop(remainder);
+ }
+ if(started) {
+- num *= base;
++ num = num * base;
+ num += remainder;
+ }
+ l10++;
+@@ -2417,7 +2417,7 @@
+ }
+ remainders.clear();
+ if(!exact && !infinite_series) {
+- remainder *= base;
++ remainder = remainder * base;
+ div = cln::truncate2(remainder, d);
+ remainder2 = div.remainder;
+ remainder = div.quotient;
diff --git a/math/libqalculate/files/patch-src-Makefile.in b/math/libqalculate/files/patch-src-Makefile.in
deleted file mode 100644
index 34cd1b4a1820..000000000000
--- a/math/libqalculate/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Tue Jun 7 10:42:56 2005
-+++ src/Makefile.in Tue Jun 7 10:44:51 2005
-@@ -530,7 +530,7 @@
-
-
- install-exec-local:
-- cd $(DESTDIR)$(bindir) && rm -f qalculate; $(LN_S) @LN_QALCULATE@ qalculate
-+# cd $(DESTDIR)$(bindir) && rm -f qalculate; $(LN_S) @LN_QALCULATE@ qalculate
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT: