summaryrefslogtreecommitdiff
path: root/math/kseg/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-09-16 18:09:03 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-09-16 18:09:03 +0000
commit94f1779d4847c6c958fbc05ccaad5a2a4b1205fb (patch)
tree7fc65694ad70aeadf16dcd24e54e5a6b247cc4bd /math/kseg/Makefile
parentUpdate to version 1.3.1 (diff)
Initial import of kset-0.3.
KSEG is a program for exploring Euclidean geometry. PR: 30305 Submitted by: Kuang-che Wu <kcwu@ck.tp.edu.tw>
Diffstat (limited to 'math/kseg/Makefile')
-rw-r--r--math/kseg/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/math/kseg/Makefile b/math/kseg/Makefile
new file mode 100644
index 000000000000..c15b8ea471b6
--- /dev/null
+++ b/math/kseg/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: kseg
+# Date created: 4 September 2001
+# Whom: Kuang-che Wu <kcwu@ck.tp.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kseg
+PORTVERSION= 0.3
+CATEGORIES= math graphics
+MASTER_SITES= http://www.mit.edu/~ibaran/
+
+MAINTAINER= kcwu@ck.tp.edu.tw
+
+USE_QT_VER= 2
+USE_X_PREFIX= yes
+
+pre-configure:
+ ${PERL} -pi -e "s@\\$$\(QTDIR\)/include@${PREFIX}/include/qt2@" ${WRKSRC}/Makefile ${WRKSRC}/formula/Makefile
+ ${PERL} -pi -e "s@\\$$\(QTDIR\)/lib -lqt@${PREFIX}/lib -lqt2@" ${WRKSRC}/Makefile
+ ${PERL} -pi -e "s@^MOC =.*@MOC = ${MOC}@" ${WRKSRC}/Makefile ${WRKSRC}/formula/Makefile
+ ${PERL} -pi -e 's@"LanguageDir", "\."@"LanguageDir", "${PREFIX}/share/doc/kseg"@' ${WRKSRC}/main.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/kseg ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/doc/kseg
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/kseg
+.for TRANS in de en fr pt xx
+ ${INSTALL_DATA} ${WRKSRC}/kseg_${TRANS}.qm ${PREFIX}/share/doc/kseg
+.endfor
+ ${MKDIR} ${PREFIX}/share/doc/kseg/examples
+ for EXAMPLES in ${WRKSRC}/examples/*;do ${INSTALL_DATA} $${EXAMPLES} ${PREFIX}/share/doc/kseg/examples;done
+
+.include <bsd.port.mk>