summaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /mail
parentAdd instructions for the libnotify and libproxy shlib bumps. (diff)
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Diffstat (limited to 'mail')
-rw-r--r--mail/balsa/Makefile4
-rw-r--r--mail/balsa/files/patch-libbalsa_information.c11
-rw-r--r--mail/balsa/files/patch-src_main-window.c11
-rw-r--r--mail/claws-mail-fancy/Makefile3
-rw-r--r--mail/claws-mail-notification/Makefile1
-rw-r--r--mail/evolution/Makefile7
-rw-r--r--mail/evolution/files/patch-calendar_gui_alarm-notify_alarm-queue.c11
-rw-r--r--mail/evolution/files/patch-plugins_mail-notification_mail-notification.c13
-rw-r--r--mail/evolution/files/patch-plugins_publish-calendar_publish-calendar.c12
-rw-r--r--mail/gnome-gmail-notifier/Makefile4
-rw-r--r--mail/gnome-gmail-notifier/files/patch-src_ggn-icon.c16
-rw-r--r--mail/thunderbird-esr/Makefile3
-rw-r--r--mail/thunderbird/Makefile3
-rw-r--r--mail/thunderbird3/Makefile4
14 files changed, 91 insertions, 12 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index 925a77cb8e73..85c77399cc47 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -8,7 +8,7 @@
PORTNAME= balsa
PORTVERSION= 2.4.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail gnome
MASTER_SITES= http://pawsa.fedorapeople.org/balsa/
DISTNAME= balsa-${PORTVERSION}
@@ -74,7 +74,7 @@ CONFIGURE_ARGS+=--with-gtksourceview=2
.endif
.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--with-libnotify=yes
.else
CONFIGURE_ARGS+=--with-libnotify=no
diff --git a/mail/balsa/files/patch-libbalsa_information.c b/mail/balsa/files/patch-libbalsa_information.c
new file mode 100644
index 000000000000..7d37e182935f
--- /dev/null
+++ b/mail/balsa/files/patch-libbalsa_information.c
@@ -0,0 +1,11 @@
+--- libbalsa/information.c.orig 2011-08-16 13:30:24.000000000 +0200
++++ libbalsa/information.c 2011-08-16 13:30:48.000000000 +0200
+@@ -122,7 +122,7 @@ libbalsa_information_varg(GtkWindow *par
+ g_free(msg);
+
+ note =
+- notify_notification_new("Balsa", escaped->str, icon_str, NULL);
++ notify_notification_new("Balsa", escaped->str, icon_str);
+ g_string_free(escaped, TRUE);
+
+ notify_notification_set_timeout(note, 7000); /* 7 seconds */
diff --git a/mail/balsa/files/patch-src_main-window.c b/mail/balsa/files/patch-src_main-window.c
new file mode 100644
index 000000000000..b376b7260ddc
--- /dev/null
+++ b/mail/balsa/files/patch-src_main-window.c
@@ -0,0 +1,11 @@
+--- src/main-window.c.orig 2011-08-16 13:32:27.000000000 +0200
++++ src/main-window.c 2011-08-16 13:33:10.000000000 +0200
+@@ -3406,7 +3406,7 @@ bw_display_new_mail_notification(int num
+ } else {
+ num_total = num_new;
+ balsa_app.main_window->new_mail_note =
+- notify_notification_new("Balsa", NULL, NULL, NULL);
++ notify_notification_new("Balsa", NULL, NULL);
+ g_object_add_weak_pointer(G_OBJECT(balsa_app.main_window->
+ new_mail_note),
+ (gpointer) & balsa_app.main_window->
diff --git a/mail/claws-mail-fancy/Makefile b/mail/claws-mail-fancy/Makefile
index c6c77b479405..874b1be9d4bc 100644
--- a/mail/claws-mail-fancy/Makefile
+++ b/mail/claws-mail-fancy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fancy
PORTVERSION= 0.9.13
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.claws-mail.org/downloads/plugins/
PKGNAMEPREFIX= claws-mail-
@@ -15,7 +16,7 @@ MAINTAINER= pawel@FreeBSD.org
COMMENT= Webkit based HTML renderer plugin for claws-mail
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- webkit:${PORTSDIR}/www/webkit-gtk2
+ webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
BUILD_DEPENDS= claws-mail>=3.7.9:${PORTSDIR}/mail/claws-mail
RUN_DEPENDS= claws-mail>=3.7.9:${PORTSDIR}/mail/claws-mail
diff --git a/mail/claws-mail-notification/Makefile b/mail/claws-mail-notification/Makefile
index b57aad680db2..60b17e5e9820 100644
--- a/mail/claws-mail-notification/Makefile
+++ b/mail/claws-mail-notification/Makefile
@@ -7,6 +7,7 @@
PORTNAME= notification
PORTVERSION= 0.27
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.claws-mail.org/downloads/plugins/
PKGNAMEPREFIX= claws-mail-
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index ef6ed6f3081b..6bc63ffda7d7 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -3,12 +3,12 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/mail/evolution/Makefile,v 1.232 2010/11/15 20:40:29 kwm Exp $
+# $MCom: ports/mail/evolution/Makefile,v 1.237 2011/04/30 20:43:20 mezz Exp $
#
PORTNAME= evolution
PORTVERSION= 2.32.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -21,13 +21,14 @@ LIB_DEPENDS= nss3.1:${PORTSDIR}/security/nss \
gtkimageview.0:${PORTSDIR}/x11-toolkits/gtkimageview
RUN_DEPENDS= ${LOCALBASE}/lib/gnome-spell/libgnome-spell-component-0.3.so:${PORTSDIR}/textproc/gnome-spell
+CONFLICTS= evolution-3.[0-9]*
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= build
USE_GETTEXT= yes
USE_GNOME= gnomeprefix gnomehack intlhack evolutiondataserver gtkhtml3 \
desktopfileutils gnomedocutils ltasneededhack gnomedesktop
-GNOME_DESKTOP_VERSION=2
USE_AUTOTOOLS= libtool
USE_GSTREAMER= yes
INSTALLS_OMF= yes
diff --git a/mail/evolution/files/patch-calendar_gui_alarm-notify_alarm-queue.c b/mail/evolution/files/patch-calendar_gui_alarm-notify_alarm-queue.c
new file mode 100644
index 000000000000..e713de004f69
--- /dev/null
+++ b/mail/evolution/files/patch-calendar_gui_alarm-notify_alarm-queue.c
@@ -0,0 +1,11 @@
+--- calendar/gui/alarm-notify/alarm-queue.c.orig 2011-03-07 20:53:40.000000000 +0100
++++ calendar/gui/alarm-notify/alarm-queue.c 2011-03-07 20:53:50.000000000 +0100
+@@ -1606,7 +1606,7 @@ popup_notification (time_t trigger, Comp
+ body = g_strdup_printf ("%s %s", start_str, time_str);
+ }
+
+- n = notify_notification_new (summary, body, "stock_appointment-reminder", NULL);
++ n = notify_notification_new (summary, body, "stock_appointment-reminder");
+ if (!notify_notification_show(n, NULL))
+ g_warning ("Could not send notification to daemon\n");
+
diff --git a/mail/evolution/files/patch-plugins_mail-notification_mail-notification.c b/mail/evolution/files/patch-plugins_mail-notification_mail-notification.c
new file mode 100644
index 000000000000..adddf1b38a77
--- /dev/null
+++ b/mail/evolution/files/patch-plugins_mail-notification_mail-notification.c
@@ -0,0 +1,13 @@
+--- plugins/mail-notification/mail-notification.c.orig 2011-03-07 21:24:25.000000000 +0100
++++ plugins/mail-notification/mail-notification.c 2011-03-07 21:24:40.000000000 +0100
+@@ -564,9 +564,7 @@ new_notify_status (EMEventTargetFolder *
+
+ notify = notify_notification_new (
+ _("New email"), safetext,
+- "mail-unread", NULL);
+- notify_notification_attach_to_status_icon (
+- notify, status_icon);
++ "mail-unread");
+
+ /* Check if actions are supported */
+ if (can_support_actions ()) {
diff --git a/mail/evolution/files/patch-plugins_publish-calendar_publish-calendar.c b/mail/evolution/files/patch-plugins_publish-calendar_publish-calendar.c
new file mode 100644
index 000000000000..55120db4c19c
--- /dev/null
+++ b/mail/evolution/files/patch-plugins_publish-calendar_publish-calendar.c
@@ -0,0 +1,12 @@
+--- plugins/publish-calendar/publish-calendar.c.orig 2011-03-07 21:12:59.000000000 +0100
++++ plugins/publish-calendar/publish-calendar.c 2011-03-07 21:14:23.000000000 +0100
+@@ -150,8 +150,7 @@ update_publish_notification (GtkMessageT
+ return;
+ }
+
+- notify = notify_notification_new (_("Calendar Publishing"), actual_msg->str, stock_name, NULL);
+- notify_notification_attach_to_status_icon (notify, status_icon);
++ notify = notify_notification_new (_("Calendar Publishing"), actual_msg->str, stock_name);
+ notify_notification_set_urgency (notify, NOTIFY_URGENCY_NORMAL);
+ notify_notification_set_timeout (notify, NOTIFY_EXPIRES_DEFAULT);
+ g_timeout_add (500, show_notify_cb, NULL);
diff --git a/mail/gnome-gmail-notifier/Makefile b/mail/gnome-gmail-notifier/Makefile
index 053a90b69c10..fafe71278a6b 100644
--- a/mail/gnome-gmail-notifier/Makefile
+++ b/mail/gnome-gmail-notifier/Makefile
@@ -7,14 +7,14 @@
PORTNAME= gnome-gmail-notifier
PORTVERSION= 0.10.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail deskutils
MASTER_SITES= GOOGLE_CODE
MAINTAINER= avl@FreeBSD.org
COMMENT= A Gmail Inbox Monitor for the GNOME2 desktop
-LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify \
+LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify \
soup-2.4:${PORTSDIR}/devel/libsoup \
gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
diff --git a/mail/gnome-gmail-notifier/files/patch-src_ggn-icon.c b/mail/gnome-gmail-notifier/files/patch-src_ggn-icon.c
new file mode 100644
index 000000000000..59bae8fbc5f3
--- /dev/null
+++ b/mail/gnome-gmail-notifier/files/patch-src_ggn-icon.c
@@ -0,0 +1,16 @@
+--- src/ggn-icon.c.orig 2011-08-16 13:36:23.000000000 +0200
++++ src/ggn-icon.c 2011-08-16 13:37:27.000000000 +0200
+@@ -566,12 +566,7 @@ gpointer ggn_icon_show_notification_thre
+ /* create a new notification. */
+ icon->priv->note = notify_notification_new (icon->priv->title,
+ icon->priv->summary,
+- icon->priv->icon_file,
+- NULL);
+-
+- /* attach the notification to our icon. */
+- notify_notification_attach_to_status_icon (icon->priv->note,
+- icon->priv->icon);
++ icon->priv->icon_file);
+
+ /* set the notification timeout. */
+ notify_notification_set_timeout (icon->priv->note, (4 * 1000));
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index c0a0e22f0904..f5b815fa8add 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thunderbird
DISTVERSION= 6.0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source
@@ -80,7 +81,7 @@ MOZ_OPTIONS+= --disable-gnomeui
MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.else
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
.endif
.if ${ARCH} == amd64 || ${ARCH} == i386
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index c0a0e22f0904..f5b815fa8add 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thunderbird
DISTVERSION= 6.0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source
@@ -80,7 +81,7 @@ MOZ_OPTIONS+= --disable-gnomeui
MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.else
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
.endif
.if ${ARCH} == amd64 || ${ARCH} == i386
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index 8edb298e7339..0306eabb0040 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= thunderbird
DISTVERSION= 3.1.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source
@@ -80,7 +80,7 @@ MOZ_OPTIONS+= --disable-gnomeui
MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.else
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
.endif
post-extract: