summaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2003-05-03 19:02:01 +0000
committerOliver Braun <obraun@FreeBSD.org>2003-05-03 19:02:01 +0000
commitb709a2a4b070e5f0a772b56e6cbe2ab55b30e14b (patch)
tree85e2da83eec42e2f8de9cfa003b8ba73b3b36bdf /mail
parentUpdate to 0.8.1. (diff)
- For POLA reasons change the default knobs. This also results in
the same installation when PACKAGE_BUILDING and when doing a "make install". - Add an installation message when using SLANG, as this won't always work for a color terminal without setting additional environment variables. - Use the same patch as the mutt port for fixing FQDN problems in FreeBSD < 5.0 PR: ports/51727 Submitted by: maintainer
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile89
-rw-r--r--mail/mutt-devel/files/patch-init.c16
2 files changed, 54 insertions, 51 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index e664741a4e56..c5c67f6147a9 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -10,7 +10,7 @@
#
# As all of the knobs have a unique name which should not interfere with
# other ports you can add them to /etc/make.conf, e.g. a line like
-# "WITH_MUTT_HTML=yes" will enable mutt's HTML documentation.
+# "WITH_MUTT_NNTP=yes" will enable mutt's nntp facilities.
#
# In addition to the knobs listed below you can enable other configuration
# options of mutt by adding them to the MUTT_CONFIGURE_ARGS variable. For
@@ -20,33 +20,45 @@
# The two most important knobs are:
#
# In general you can choose between using the SLANG port (WITH_MUTT_SLANG)
-# and ncurses (WITH_MUTT_NCURSES) which is the default.
+# and ncurses (WITH_MUTT_NCURSES) which is the default. Note that you may
+# have to set the variables COLORTERM=yes and COLORFGBG=color,color in your
+# environment to get slang function properly.
#
# If you want to install the mutt documentation in html and ps format define:
# WITH_MUTT_HTML
+# This is a default knob and can be disabled by WITHOUT_MUTT_HTML
#
# If you do not want that the documentation is rebuilt using sgmlformat
# define:
# WITHOUT_MUTT_SGMLFORMAT
-# (this can't be stated if WITH_MUTT_HTML is defined)
-#
-# If you want to read and post news with mutt define:
-# WITH_MUTT_NNTP
-#
-# WITH_MUTT_SSL can be enabled if your IMAP/POP server is SSL capable.
-#
-# If you want to use the SASL authentication features with your email server
-# define
-# WITH_MUTT_CYRUS_SASL
+# (this can only be stated if WITHOUT_MUTT_HTML is defined)
#
# If you want to access compressed email folders define:
# WITH_MUTT_COMPRESSED_FOLDERS
+# This is a default knob and can be disabled by WITHOUT_MUTT_COMPRESSED_FOLDERS
#
# If you want to enable extended quoting functions define:
# WITH_MUTT_QUOTE_PATCH
+# This is a default knob and can be disabled by WITHOUT_MUTT_QUOTE_PATCH
+#
+# WITH_MUTT_SSL can be enabled if your IMAP/POP server is SSL capable.
+# This is a default knob and can be disabled by WITHOUT_MUTT_SSL
#
# If you want to make SMIME outlook compatible define:
# WITH_MUTT_SMIME_OUTLOOK_COMPAT
+# This is a default knob and can be disabled by
+# WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT
+#
+# If you want to use enhanced pgp features define:
+# WITH_MUTT_PGP_PATCH
+# This is a default knob and can be disabled by WITHOUT_MUTT_PGP_PATCH
+#
+# If you want to read and post news with mutt define:
+# WITH_MUTT_NNTP
+#
+# If you want to use the SASL authentication features with your email server
+# define
+# WITH_MUTT_CYRUS_SASL
#
# If you want to use the rethreading functions define:
# WITH_MUTT_EDIT_THREADS
@@ -54,9 +66,6 @@
# If you want to use the signature menu define:
# WITH_MUTT_SIGNATURE_MENU
#
-# If you want to use enhanced pgp features define:
-# WITH_MUTT_PGP_PATCH
-#
# If you want to use the printf-like enhancement to the mbox-hook command
# define:
# WITH_MUTT_MBOX_HOOK_PATCH
@@ -102,6 +111,7 @@ USE_REINPLACE= yes
USE_AUTOMAKE= yes
PLIST= ${WRKDIR}/PLIST
+PKGMESSAGE= ${WRKDIR}/pkg-message
SCRIPTS_ENV= WRKDIR="${WRKDIR}"
.include <bsd.port.pre.mk>
@@ -128,21 +138,11 @@ pre-build:
${BUILD_WRKSRC}/Makefile
.if defined(PACKAGE_BUILDING)
-WITH_MUTT_SSL= yes
-WITH_MUTT_SLANG= yes
-WITH_MUTT_HTML= yes
-WITH_MUTT_COMPRESSED_FOLDERS= yes
-WITH_MUTT_QUOTE_PATCH= yes
-WITH_MUTT_SMIME_OUTLOOK_COMPAT= yes
-WITH_MUTT_PGP_PATCH= yes
BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell \
urlview:${PORTSDIR}/textproc/urlview
.endif
-.if defined(WITH_MUTT_PS)
-WITH_MUTT_HTML= yes
-.endif
.if defined(WITH_MUTT_NCURSES_PORT)
WITH_MUTT_NCURSES= yes
.endif
@@ -173,18 +173,18 @@ CFLAGS+= -I${PREFIX}/include/ncurses -I${PREFIX}/include
.elif defined(USE_SLANG)
LIB_DEPENDS+= slang.1:${PORTSDIR}/devel/libslang
.endif
-.if defined(WITH_MUTT_SSL)
+.if !defined(WITHOUT_MUTT_SSL)
USE_OPENSSL= yes
.endif
.if defined(WITH_MUTT_CYRUS_SASL)
LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
.endif
-.if defined(WITH_MUTT_SMIME_OUTLOOK_COMPAT)
+.if ! defined(WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT)
pre-configure::
${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-smime-outlook
.endif
-.if defined(WITH_MUTT_PGP_PATCH)
+.if ! defined(WITHOUT_MUTT_PGP_PATCH)
SGML_NEEDED= yes
pre-configure::
${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-pgp-dw
@@ -198,7 +198,7 @@ CONFIGURE_ARGS+= --with-curses=${PREFIX}
.elif defined(USE_SLANG)
CONFIGURE_ARGS+= --with-slang=${PREFIX}
.endif
-.if defined(WITH_MUTT_SSL)
+.if !defined(WITHOUT_MUTT_SSL)
CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
.endif
.if defined(WITH_MUTT_CYRUS_SASL)
@@ -207,7 +207,7 @@ CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
PATCH_DIST_STRIP= -p1
-.if defined(WITH_MUTT_COMPRESSED_FOLDERS)
+.if ! defined (WITHOUT_MUTT_COMPRESSED_FOLDERS)
PATCHFILES+= patch-${VVV_PATCH_VERSION}.rr.compressed.gz:vvv
CONFIGURE_ARGS+= --enable-compressed
SGML_NEEDED= yes
@@ -217,7 +217,7 @@ PATCHFILES+= patch-${VVV_PATCH_VERSION}.vvv.nntp.gz:vvv
CONFIGURE_ARGS+= --enable-nntp
SGML_NEEDED= yes
.endif
-.if defined(WITH_MUTT_QUOTE_PATCH)
+.if ! defined(WITHOUT_MUTT_QUOTE_PATCH)
PATCHFILES+= patch-${VVV_PATCH_VERSION}.vvv.initials.gz:vvv \
patch-${VVV_PATCH_VERSION}.vvv.quote.gz:vvv
SGML_NEEDED= yes
@@ -254,10 +254,10 @@ pre-configure::
.if defined(WITH_MUTT_NNTP)
SCRIPTS_ENV+= MUTT_NNTP="yes"
.endif
-.if defined(WITH_MUTT_COMPRESSED_FOLDERS)
+.if ! defined (WITHOUT_MUTT_COMPRESSED_FOLDERS)
SCRIPTS_ENV+= MUTT_COMPRESSED_FOLDERS="yes"
.endif
-.if defined(WITH_MUTT_QUOTE_PATCH)
+.if ! defined(WITHOUT_MUTT_QUOTE_PATCH)
SCRIPTS_ENV+= MUTT_QUOTE_PATCH="yes"
.endif
.if defined(WITH_MUTT_EDIT_THREADS)
@@ -269,10 +269,10 @@ SCRIPTS_ENV+= MUTT_SIGNATURE_MENU="yes"
.if defined(WITH_MUTT_IFDEF_PATCH)
SCRIPTS_ENV+= MUTT_IFDEF_PATCH="yes"
.endif
-.if defined(WITH_MUTT_PGP_PATCH)
+.if ! defined(WITHOUT_MUTT_PGP_PATCH)
SCRIPTS_ENV+= MUTT_PGP_PATCH="yes"
.endif
-.if defined(WITH_MUTT_HTML)
+.if ! defined(WITHOUT_MUTT_HTML)
SCRIPTS_ENV+= MUTT_HTML="yes"
.endif
@@ -282,7 +282,7 @@ post-build:
${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-doc-ref
printf ",s|\$${PREFIX}|%s|g\nw\nq\n" ${PREFIX} | \
ed -s ${WRKSRC}/doc/mutt.man
-.if defined(WITH_MUTT_HTML)
+.if ! defined(WITHOUT_MUTT_HTML)
SGML_USED= yes
.endif
.if defined(SGML_NEEDED) && !defined(WITHOUT_MUTT_SGMLFORMAT)
@@ -304,6 +304,7 @@ pre-install:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/generate-plist > ${PLIST}
post-install:
+ @${ECHO} > ${PKGMESSAGE}
.if !defined(NOPORTDOCS)
@${ECHO} "===> Installing Mutt documentation"
@${MKDIR} ${PREFIX}/share/doc/mutt && \
@@ -319,11 +320,23 @@ post-install:
@cd ${WRKSRC} ; ${INSTALL_MAN} ChangeLog.nntp \
${PREFIX}/share/doc/mutt
.endif
-.if defined(WITH_MUTT_HTML)
+.if ! defined(WITHOUT_MUTT_HTML)
@${MKDIR} ${PREFIX}/share/doc/mutt/html && \
${CHMOD} a+rx ${PREFIX}/share/doc/mutt/html
${INSTALL_MAN} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/mutt/html
.endif
.endif
-
+.if defined(USE_SLANG)
+ @${ECHO} "====================================================" >> ${PKGMESSAGE}
+ @${ECHO} "You have installed ${PORTNAME} with SLANG support." >> ${PKGMESSAGE}
+ @${ECHO} "This may work for a color terminal only when defining" >> ${PKGMESSAGE}
+ @${ECHO} "COLORTERM=yes and COLORFGBG=color,color in your" >> ${PKGMESSAGE}
+ @${ECHO} "environment." >> ${PKGMESSAGE}
+ @${ECHO} "====================================================" >> ${PKGMESSAGE}
+.endif
+.if !defined(BATCH)
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+.endif
.include <bsd.port.post.mk>
diff --git a/mail/mutt-devel/files/patch-init.c b/mail/mutt-devel/files/patch-init.c
index 4d0363a9c1bb..389b682cfa11 100644
--- a/mail/mutt-devel/files/patch-init.c
+++ b/mail/mutt-devel/files/patch-init.c
@@ -1,16 +1,6 @@
--- init.c.orig Wed Jul 24 10:41:29 2002
-+++ init.c Wed Apr 30 13:06:45 2003
-@@ -45,7 +45,9 @@
- #include <stdlib.h>
- #include <unistd.h>
- #include <string.h>
-+#if __FreeBSD_version >= 500000
- #include <sys/utsname.h>
-+#endif
- #include <errno.h>
- #include <sys/wait.h>
-
-@@ -1707,7 +1709,11 @@
++++ init.c Sat May 3 08:46:29 2003
+@@ -1707,7 +1707,11 @@
void mutt_init (int skip_sys_rc, LIST *commands)
{
struct passwd *pw;
@@ -22,7 +12,7 @@
char *p, buffer[STRING], error[STRING];
int i, default_rc = 0, need_pause = 0;
BUFFER err;
-@@ -1765,16 +1771,21 @@
+@@ -1765,16 +1769,21 @@
#endif
/* And about the host... */