summaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2002-02-07 10:32:26 +0000
committerPeter Pentchev <roam@FreeBSD.org>2002-02-07 10:32:26 +0000
commit9797ec1723b226829a0b0489affcddb765bb0196 (patch)
tree1351856d8ab7e0ce50d0c800c1acea81bb919f1a /mail
parentInstall missing file java.bnf. (diff)
Update autorespond to 2.0.2, adding a patch to comment out
a definition of strcasestr(), which is already provided by our libc's <string.h>. Take over maintainership from Neil Blakey-Milner with many thanks for his work on this and other ports! PR: 34024 Submitted by: Oliver Lehmann <lehmann@ans-netz.de> Approved by: nbm (former maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/autorespond/Makefile6
-rw-r--r--mail/autorespond/distinfo2
-rw-r--r--mail/autorespond/files/patch-autorespond.c19
3 files changed, 23 insertions, 4 deletions
diff --git a/mail/autorespond/Makefile b/mail/autorespond/Makefile
index b37ad82e40f7..d446f97fc6a5 100644
--- a/mail/autorespond/Makefile
+++ b/mail/autorespond/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= autorespond
-PORTVERSION= 1.0.0
+PORTVERSION= 2.0.2
CATEGORIES= mail
-MASTER_SITES= http://www.vpopmail.cx/
+MASTER_SITES= http://www.inter7.com/devel/
-MAINTAINER= nbm@FreeBSD.org
+MAINTAINER= roam@FreeBSD.org
do-build:
@cd ${WRKSRC} && ${MAKE} autorespond
diff --git a/mail/autorespond/distinfo b/mail/autorespond/distinfo
index 7f6fc19c3ac7..8dbf45404ed1 100644
--- a/mail/autorespond/distinfo
+++ b/mail/autorespond/distinfo
@@ -1 +1 @@
-MD5 (autorespond-1.0.0.tar.gz) = 915977b3db335cdfa51e18cd660fce95
+MD5 (autorespond-2.0.2.tar.gz) = aa81f2c02b36ccd3ce58c60f0f89683e
diff --git a/mail/autorespond/files/patch-autorespond.c b/mail/autorespond/files/patch-autorespond.c
new file mode 100644
index 000000000000..1dc4a73a97fd
--- /dev/null
+++ b/mail/autorespond/files/patch-autorespond.c
@@ -0,0 +1,19 @@
+--- autorespond.c Thu Feb 7 12:07:44 2002
++++ autorespond.c Thu Feb 7 12:07:59 2002
+@@ -377,6 +377,7 @@
+ /*********************************************************
+ ** find string in string - ignore case **/
+
++/*
+ char *strcasestr( char *_s1, char *_s2 )
+ {
+ char *s1;
+@@ -399,7 +400,7 @@
+ else
+ return _s1 + (ptr - s1);
+ }
+-
++*/
+
+
+