summaryrefslogtreecommitdiff
path: root/mail/xfmail/Makefile
diff options
context:
space:
mode:
authorMike Heffner <mikeh@FreeBSD.org>2001-07-08 15:37:17 +0000
committerMike Heffner <mikeh@FreeBSD.org>2001-07-08 15:37:17 +0000
commitad149bc78e2fef3a446c2bb01595db0c2ee8a6cf (patch)
tree62f3dba3314d064517d7dd1ce7d1b85a4b8eb414 /mail/xfmail/Makefile
parentFix build for packages (diff)
Revert last commit and fix for libtool. Also add optional esound support.
Submitted by: Pete Fritchman <petef@databits.net> (esound support)
Diffstat (limited to 'mail/xfmail/Makefile')
-rw-r--r--mail/xfmail/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/mail/xfmail/Makefile b/mail/xfmail/Makefile
index aa2131ad3a1f..de4814642978 100644
--- a/mail/xfmail/Makefile
+++ b/mail/xfmail/Makefile
@@ -22,15 +22,26 @@ USE_AUTOMAKE= yes
USE_BZIP2= yes
USE_GLIB= yes
USE_GMAKE= yes
+USE_LIBTOOL= yes
USE_X_PREFIX= yes
USE_XPM= yes
+# XXX: Disable patching for libtool until we can generate the files
+LIBTOOLFILES=
+
.include <bsd.port.pre.mk>
CONFIGURE_ARGS= --with-dbm-lib=gdbm
+
+.if defined(WITH_ESOUND)
+USE_ESOUND= yes
+CONFIGURE_ARGS+= --with-esd-sound
+.endif
+
MAN1= xfmail.1
pre-configure:
- @cd ${WRKSRC} && ${SH} autogen.sh
+ @(cd ${WRKSRC} && ${SH} autogen.sh); \
+ ${MAKE} LIBTOOLFILES=aclocal.m4 patch-libtool
.include <bsd.port.post.mk>