summaryrefslogtreecommitdiff
path: root/mail/vexim
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-21 20:36:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-21 20:36:10 +0000
commit00cffa5982bf661e1769894687dfce76dfe26ee8 (patch)
tree640e5483a899f9a715813d73663246047cd02fa9 /mail/vexim
parent- Update to 1.04 (diff)
- Optionalize MySQL/PgSQL support
PR: ports/90110 Submitted by: James O'Gorman <james@netinertia.co.uk> Approved by: John Oxley <john@yoafrica.com> (maintainer)
Diffstat (limited to 'mail/vexim')
-rw-r--r--mail/vexim/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/mail/vexim/Makefile b/mail/vexim/Makefile
index 44a12ed77d71..844d31bc7ecf 100644
--- a/mail/vexim/Makefile
+++ b/mail/vexim/Makefile
@@ -17,12 +17,23 @@ VEXIMDIR= www/${PORTNAME}
WRKSRC= ${WRKDIR}/vexim2
SUB_FILES= pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
NO_BUILD= yes
-USE_MYSQL= yes
USE_APACHE= yes
USE_PHP= yes
+OPTIONS= MYSQL "Use MySQL" On \
+ PGSQL "Use PostgreSQL" Off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_MYSQL) && !defined(WITH_PGSQL)
+USE_MYSQL= yes
+.endif
+
+.if defined(WITH_PGSQL)
+WITH_PGSQL= yes
+.endif
+
post-patch:
${FIND} ${WRKSRC} -name CVS -prune -exec ${RM} -r {} \;
@@ -49,4 +60,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>