summaryrefslogtreecommitdiff
path: root/mail/thunderbird-i18n/Makefile
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2014-10-15 15:48:16 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2014-10-15 15:48:16 +0000
commit8f7f02ae397da7ce0cf9c3bc16b5d117807c1949 (patch)
treec910dffa13397137a5faa661668aff88ff8d1a77 /mail/thunderbird-i18n/Makefile
parent- Allow svnup to work with TLS; SSLv3 is being disabled due to POODLE. (diff)
- Update Firefox to 33.0
- Update Firefox ESR to 31.2.0 - Update NSS to 3.17.2 - Update Thunderbird to 31.2.0 - Update libxul to 31.2.0 (and mark as BROKEN) - Disable SSL 3.0 with pref (Upstream bug 1076983) - (workaround) replace USE_GCC=yes with USES=compiler:gcc-c++11-lib in order to fix runtime for PGO and powerpc/powerpc64 on libc++ systems - Add OSS audio fallback for HTML5 audio from upstream bug; not exposed yet because WebRTC still needs ALSA or PulseAudio - Kill @dirrm from gecko@ ports per CHANGES from 20140922 - Drop workaround for LLVM PR 19007: base and lang/clang34 have the fix - Improve workaround comment for LLVM PR 15840, partially rejecting r348851 by marino@ until bug 193555 PR: 194356 Submitted by: Jan Beich Security: http://www.vuxml.org/freebsd/9c1495ac-8d8c-4789-a0f3-8ca6b476619c.html
Diffstat (limited to 'mail/thunderbird-i18n/Makefile')
-rw-r--r--mail/thunderbird-i18n/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/mail/thunderbird-i18n/Makefile b/mail/thunderbird-i18n/Makefile
index 33cae5f85072..11dd8bcc67ec 100644
--- a/mail/thunderbird-i18n/Makefile
+++ b/mail/thunderbird-i18n/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= thunderbird-i18n
-PORTVERSION= 31.1.2
+PORTVERSION= 31.2.0
CATEGORIES= mail news net-im
MASTER_SITES= MOZILLA/${PORTNAME:S|-i18n||}/releases/${PORTVERSION}/linux-i686/xpi
PKGNAMEPREFIX=
@@ -12,7 +12,7 @@ DIST_SUBDIR= xpi/${DISTNAME}
MAINTAINER= gecko@FreeBSD.org
COMMENT= Localized interface for Thunderbird
-USES= gecko:thunderbird zip
+USES= gecko:thunderbird,build zip
USE_XPI= thunderbird
NO_BUILD= yes
@@ -24,15 +24,11 @@ WDIR= langpack-*@thunderbird.mozilla.org
XPI_DISTNAMES= ${THUNDERBIRD_I18N_}
PLIST?= ${WRKDIR}/plist
-PLISTD?= ${WRKDIR}/plist_dirs
PLISTF?= ${WRKDIR}/plist_files
.include "${.CURDIR}/Makefile.option"
.include <bsd.port.pre.mk>
-# make sure that thunderbird always gets upgraded before this port
-BUILD_DEPENDS= thunderbird>=0:${PORTSDIR}/mail/thunderbird
-
.ifndef WITHOUT_SWITCHER
RUN_DEPENDS+= xpi-quick-locale-switcher>=0:${PORTSDIR}/www/xpi-quick-locale-switcher
.endif
@@ -55,12 +51,9 @@ do-extract:
fi; \
cd ${WRKSRC}/langpack-$$lang@thunderbird.mozilla.org/; \
${FIND} -H -s * ! -type d | \
- ${SED} -e "s|^|lib/xpi/langpack-$$lang@thunderbird.mozilla.org/|" >> ${PLISTF} && \
- ${FIND} -d * -type d | \
- ${SED} -e "s|^|@dirrm lib/xpi/langpack-$$lang@thunderbird.mozilla.org/|" >> ${PLISTD}; \
+ ${SED} -e "s|^|lib/xpi/langpack-$$lang@thunderbird.mozilla.org/|" >> ${PLISTF}; \
done
${CAT} ${PLISTF} | ${SORT} >> ${PLIST}
- ${CAT} ${PLISTD} | ${SORT} -r >> ${PLIST}
do-install: