summaryrefslogtreecommitdiff
path: root/mail/sigit/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-08-26 04:55:22 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-08-26 04:55:22 +0000
commit6be5f1bed3b8889e67c740025e0f995f8991ed03 (patch)
tree8a63f16ee9750c5b24c007b2c13b3660ad4aa5db /mail/sigit/Makefile
parentFix a pthread compilation problem on -stable. (diff)
add sigit 0.0.4
A tool to create random signatures PR: 29881
Diffstat (limited to 'mail/sigit/Makefile')
-rw-r--r--mail/sigit/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/mail/sigit/Makefile b/mail/sigit/Makefile
new file mode 100644
index 000000000000..a48a240dd9fd
--- /dev/null
+++ b/mail/sigit/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: sigit
+# Date created: 18 August 2001
+# Whom: petef
+#
+# $FreeBSD$
+#
+
+PORTNAME= sigit
+PORTVERSION= 0.0.4
+CATEGORIES= mail
+MASTER_SITES= http://www.math.ku.dk/~m99khn/download/stable/
+
+MAINTAINER= petef@FreeBSD.org
+
+USE_GMAKE= yes
+
+MAN1= sigit.1 sigit.rc.1
+
+post-patch:
+ @${PERL} -pi -e 's,/etc/sigit.rc,${PREFIX}/etc/sigit.rc,; \
+ s,/usr/share/sigit,${DATADIR},' ${WRKSRC}/config.h
+
+post-install:
+ @(if [ ! -f ${PREFIX}/etc/sigit.rc ]; then \
+ ${CP} ${PREFIX}/etc/sigit.rc.dist ${PREFIX}/etc/sigit.rc; fi)
+
+.include <bsd.port.mk>