summaryrefslogtreecommitdiff
path: root/mail/postfix27/Makefile
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-12-28 23:47:11 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-12-28 23:47:11 +0000
commite329c90b81748dab416f62b6be10fe85fa0b1e67 (patch)
tree1810e41ebc571642deca6adb6600d84680ae4ee2 /mail/postfix27/Makefile
parent- Update to 0.69 (diff)
Add OPTION for SASL authentication via Dovecot 2.x and
warn users if they erroneously elect both 1.x and 2.x. No bump of PORTREVISION because the default package is unchanged.
Diffstat (limited to '')
-rw-r--r--mail/postfix27/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/mail/postfix27/Makefile b/mail/postfix27/Makefile
index d69c0d84c0f3..85462df57726 100644
--- a/mail/postfix27/Makefile
+++ b/mail/postfix27/Makefile
@@ -41,7 +41,8 @@ STATUS_${o}=on
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" ${STATUS_SASL2} \
- DOVECOT "Dovecot SASL authentication method" off \
+ DOVECOT "Dovecot 1.x SASL authentication method" off \
+ DOVECOT2 "Dovecot 2.x SASL authentication method" off \
SASLKRB5 "If your SASL req. Kerberos5 select this option" ${STATUS_SASLKRB5} \
SASLKMIT "If your SASL req. MIT Kerberos5 select this option" ${STATUS_SASLKRB5MIT} \
TLS "Enable SSL and TLS support" ${STATUS_TLS} \
@@ -122,8 +123,16 @@ POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOC
POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
+.if defined(WITH_DOVECOT) && defined(WITH_DOVECOT2)
+BROKEN= Select only one Dovecot option
+.endif
+
+.if defined(WITH_DOVECOT) || defined(WITH_DOVECOT2)
.if defined(WITH_DOVECOT)
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
+.else
+RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot2
+.endif
POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DDEF_SERVER_SASL_TYPE=\\\"dovecot\\\"
_REQUIRE+= dovecot
.endif