summaryrefslogtreecommitdiff
path: root/mail/openwebmail/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-04-06 06:30:54 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-04-06 06:30:54 +0000
commit18074c438ca7db07b4186189739f5b0f84755118 (patch)
treebb2ab658e164826f5dc04bf7c1a004ef521a91d3 /mail/openwebmail/Makefile
parentAdd gtk-aqualightblue-theme, a Mac OS X like theme for GTK+-2. (diff)
unbreak openwebmail when it's installed in fresh-built environment.
use "tar cf" and "tar xf" instead of "cp -R". generate real PLIST in do-install phase. Noticed by: kris and bento
Diffstat (limited to 'mail/openwebmail/Makefile')
-rw-r--r--mail/openwebmail/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/mail/openwebmail/Makefile b/mail/openwebmail/Makefile
index 9ebb84655377..700d15befb4c 100644
--- a/mail/openwebmail/Makefile
+++ b/mail/openwebmail/Makefile
@@ -20,12 +20,14 @@ RUN_DEPENDS= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
${SITE_PERL}/${PERL_ARCH}/Text/Iconv.pm:${PORTSDIR}/converters/p5-Text-Iconv \
${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+USE_PERL5= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
OWCGIDIR= ${PREFIX}/www/cgi-bin/openwebmail
OWDATADIR= ${PREFIX}/www/data/openwebmail
PATCH_WRKSRC= ${WRKSRC}/cgi-bin/openwebmail
PATCH_STRIP= -p1
+PLIST= ${WRKDIR}/.PLIST.openwebmail
.if defined(WITH_SPEEDYCGI)
BUILD_DEPENDS+= ${SITE_PERL}/CGI/SpeedyCGI.pm:${PORTSDIR}/www/p5-CGI-SpeedyCGI
@@ -78,13 +80,18 @@ post-patch:
.endif
do-install:
- @${CP} -R ${WRKSRC}/cgi-bin/openwebmail/ ${OWCGIDIR}
- @${CP} -R ${WRKSRC}/data/openwebmail/ ${OWDATADIR}
+ @${MKDIR} ${OWCGIDIR:S,${PORTNAME},,}
+ @cd ${WRKSRC}/cgi-bin && ${TAR} cf - ${PORTNAME} | (cd ${OWCGIDIR:S,${PORTNAME},,}; ${TAR} xf -)
+ @${MKDIR} ${OWDATADIR:S,${PORTNAME},,}
+ @cd ${WRKSRC}/data && ${TAR} cf - ${PORTNAME} | (cd ${OWDATADIR:S,${PORTNAME},,}; ${TAR} xf -)
@${CHOWN} -R root:mail ${OWCGIDIR}
@${CHMOD} 0770 ${OWCGIDIR}/etc/sessions ${OWCGIDIR}/etc/users
@${CHMOD} 4755 ${OWCGIDIR}/openwebmail*pl
@${PERL} ${OWCGIDIR}/uty/wrapsuid.pl ${OWCGIDIR}
@${OWCGIDIR}/openwebmail-tool.pl --init --no
@${FIND} ${OWCGIDIR} \( -name "*.bak" -or -name "*.orig" \) -delete
+ @${RM} -f ${PLIST}
+ @cd ${PREFIX} && ${FIND} ${OWCGIDIR:S,${PREFIX}/,,} ${OWDATADIR:S,${PREFIX}/,,} -type f -or -type l | sort -u > ${PLIST}
+ @cd ${PREFIX} && ${FIND} ${OWCGIDIR:S,${PREFIX}/,,} ${OWDATADIR:S,${PREFIX}/,,} -type d | sort -ur | ${SED} -e 's,^,@dirrm ,g' >> ${PLIST}
.include <bsd.port.mk>