summaryrefslogtreecommitdiff
path: root/mail/fetchyahoo/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2004-04-20 21:10:28 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2004-04-20 21:10:28 +0000
commitb68712e90f9a17301a3da924b51e553218539277 (patch)
tree5711594b818e0b2876954b1ab2ad42247109860e /mail/fetchyahoo/Makefile
parent- Rename WITH_POSTGRES knob to WITH_POSTGRESQL to be consistent (diff)
Use PLIST_DIRS, PLIST_FILES and PORTDOCS.
Install example rc file even if NOPORTDOCS is set. Do not depend on p5-Net when using Perl 5.8. PR: 64870 Submitted by: leeym Also be less verbose.
Diffstat (limited to '')
-rw-r--r--mail/fetchyahoo/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/mail/fetchyahoo/Makefile b/mail/fetchyahoo/Makefile
index 2479bac7731a..56afe7f90d53 100644
--- a/mail/fetchyahoo/Makefile
+++ b/mail/fetchyahoo/Makefile
@@ -18,37 +18,33 @@ RUN_DEPENDS= \
${SITE_PERL}/IO/Lines.pm:${PORTSDIR}/devel/p5-IO-stringy \
${SITE_PERL}/MIME/Body.pm:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools \
- ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
-${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
${SITE_PERL}/${PERL_ARCH}/HTML/Filter.pm:${PORTSDIR}/www/p5-HTML-Parser\
${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww
-DOCS= COPYING ChangeLog Credits INSTALL TODO index.html
MAN1= fetchyahoo.1
+PLIST_DIRS= share/examples/fetchyahoo
+PLIST_FILES= bin/fetchyahoo share/examples/fetchyahoo/fetchyahoorc
+PORTDOCS= COPYING ChangeLog Credits INSTALL TODO index.html
NO_BUILD= yes
-PLIST= ${WRKDIR}/pkg-plist
USE_PERL5= yes
.include <bsd.port.pre.mk>
-pre-install:
- ${ECHO_CMD} bin/fetchyahoo > ${PLIST}
-.if !defined(NOPORTDOCS)
- ${ECHO_CMD} share/examples/fetchyahoo/fetchyahoorc >> ${PLIST}
-.for ii in ${DOCS}
- ${ECHO_CMD} share/doc/fetchyahoo/${ii} >> ${PLIST}
-.endfor
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS+= ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net
.endif
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/fetchyahoo ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ @${INSTALL_SCRIPT} ${WRKSRC}/fetchyahoo ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/fetchyahoorc ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/fetchyahoorc ${EXAMPLESDIR}
-.for ii in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+.for ii in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
.endfor
.endif