summaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
commit9839011ec3910790376ce9ace5e2a1c5bcb2781f (patch)
tree41c61966bf1404bd3cfce06493a35d6a1a4acfc6 /lang
parentRemove support for antique perl. (diff)
Welcome bsd.perl.mk. Add support for constructs such as USE_PERL5=5.8.0+.
Drop support for antique perl. Work done by: gabor Sponsored by: Google Summer of Code 2007 Hat: portmgr
Diffstat (limited to 'lang')
-rw-r--r--lang/ghc/Makefile4
-rw-r--r--lang/p5-Expect/Makefile10
-rw-r--r--lang/p5-Interpolation/Makefile8
-rw-r--r--lang/p5-JSAN/Makefile8
-rw-r--r--lang/p5-JavaScript-SpiderMonkey/Makefile12
-rw-r--r--lang/p5-Perl6-Subs/Makefile10
-rw-r--r--lang/p5-Quantum-Superpositions/Makefile11
-rw-r--r--lang/parrot/Makefile6
-rw-r--r--lang/perl5.10/Makefile7
-rw-r--r--lang/perl5.12/Makefile7
-rw-r--r--lang/perl5.14/Makefile7
-rw-r--r--lang/perl5.16/Makefile7
-rw-r--r--lang/perl5.6/Makefile7
-rw-r--r--lang/perl5.8/Makefile7
-rw-r--r--lang/perl5/Makefile7
-rw-r--r--lang/pike76/Makefile6
16 files changed, 59 insertions, 65 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index aba08019649e..f63f430ffaa2 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -44,10 +44,6 @@ IGNORE= unsupported at the moment
IGNORE= unsupported at the moment
.endif
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires newer version of perl
-.endif
-
USE_AUTOTOOLS= autoconf:259:env
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4 \
readline.5:${PORTSDIR}/devel/readline
diff --git a/lang/p5-Expect/Makefile b/lang/p5-Expect/Makefile
index 4005e7b0f992..e6c129a95f42 100644
--- a/lang/p5-Expect/Makefile
+++ b/lang/p5-Expect/Makefile
@@ -17,14 +17,8 @@ COMMENT= Perl module inspired by the Tcl version of Expect
BUILD_DEPENDS= p5-IO-Tty>=1.03:${PORTSDIR}/devel/p5-IO-Tty
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
MAN3= Expect.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires perl 5.8.0 or higher. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/p5-Interpolation/Makefile b/lang/p5-Interpolation/Makefile
index 5a84bda0696c..60d2c7e89038 100644
--- a/lang/p5-Interpolation/Makefile
+++ b/lang/p5-Interpolation/Makefile
@@ -22,10 +22,4 @@ PERL_CONFIGURE= yes
MAN3= Interpolation.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/p5-JSAN/Makefile b/lang/p5-JSAN/Makefile
index ca5e6411c18c..73a144295934 100644
--- a/lang/p5-JSAN/Makefile
+++ b/lang/p5-JSAN/Makefile
@@ -37,14 +37,8 @@ PERL_CONFIGURE= yes
MAN3= JSAN::Shell.3 JSAN.3 JSAN::Indexer::Creator.3 JSAN::Indexer.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "40 s,new,new(\'jsan\')," ${WRKSRC}/lib/JSAN.pm
${FIND} ${WRKSRC}/lib -name "*.bak" -delete
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/p5-JavaScript-SpiderMonkey/Makefile b/lang/p5-JavaScript-SpiderMonkey/Makefile
index b275bd31bcc5..25d0e9bb88e9 100644
--- a/lang/p5-JavaScript-SpiderMonkey/Makefile
+++ b/lang/p5-JavaScript-SpiderMonkey/Makefile
@@ -28,14 +28,4 @@ post-patch:
MAN3= JavaScript::SpiderMonkey.3
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000 #inherited from lang/spidermonkey
-BROKEN= does not compile on FreeBSD 4.x
-.endif
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/p5-Perl6-Subs/Makefile b/lang/p5-Perl6-Subs/Makefile
index 6eefd15ff1ec..f2940f493256 100644
--- a/lang/p5-Perl6-Subs/Makefile
+++ b/lang/p5-Perl6-Subs/Makefile
@@ -20,14 +20,8 @@ BUILD_DEPENDS= ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simp
${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.4+
MAN3= Perl6::Subs.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500804
-IGNORE= requires perl 5.8.4 or later. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/p5-Quantum-Superpositions/Makefile b/lang/p5-Quantum-Superpositions/Makefile
index d59d803c1709..559abb86733c 100644
--- a/lang/p5-Quantum-Superpositions/Makefile
+++ b/lang/p5-Quantum-Superpositions/Makefile
@@ -22,13 +22,4 @@ MAN3= Quantum::Superpositions.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-post-patch:
- @${PERL} -pi -e 's/^our (\$$VERSION)/use vars qw($$1); $$1/;' \
- -e '$$_ = "" if /use warnings/;' \
- ${WRKSRC}/lib/Quantum/Superpositions.pm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index b7f7fbd23e7c..475642f24340 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
icudata.36:${PORTSDIR}/devel/icu
USE_GCC= 3.4+
-USE_PERL5= yes
+USE_PERL5= 5.8.0+
USE_GMAKE= yes
INSTALLS_SHLIB= yes
@@ -79,8 +79,4 @@ PLIST_SUB+= JIT="@comment "
BROKEN= Does not compile on ia64
.endif
-.if ${PERL_LEVEL} < 500800
-IGNORE= perl 5.8 or newer required. Install lang/perl5.8 and try again
-.endif
-
.include <bsd.port.post.mk>
diff --git a/lang/perl5.10/Makefile b/lang/perl5.10/Makefile
index 725f1b4d0b44..4ec9934273c7 100644
--- a/lang/perl5.10/Makefile
+++ b/lang/perl5.10/Makefile
@@ -26,6 +26,8 @@ COMMENT= Practical Extraction and Report Language
PERL_VER= 5.8.8
PERL_ARCH= mach
PERL_VERSION= ${PERL_VER}
+SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
+SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
USE_BZIP2= yes
HAS_CONFIGURE= yes
@@ -51,6 +53,11 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
.include "Makefile.man"
.include <bsd.port.pre.mk>
+PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ SITE_PERL=${SITE_PERL:S|^${LOCALBASE}/||}
+
.if defined(WITH_DEBUGGING)
CONFIGURE_ARGS+= -Doptimize="-g" -DDEBUGGING
STRIP=
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index 725f1b4d0b44..4ec9934273c7 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -26,6 +26,8 @@ COMMENT= Practical Extraction and Report Language
PERL_VER= 5.8.8
PERL_ARCH= mach
PERL_VERSION= ${PERL_VER}
+SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
+SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
USE_BZIP2= yes
HAS_CONFIGURE= yes
@@ -51,6 +53,11 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
.include "Makefile.man"
.include <bsd.port.pre.mk>
+PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ SITE_PERL=${SITE_PERL:S|^${LOCALBASE}/||}
+
.if defined(WITH_DEBUGGING)
CONFIGURE_ARGS+= -Doptimize="-g" -DDEBUGGING
STRIP=
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index 725f1b4d0b44..4ec9934273c7 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -26,6 +26,8 @@ COMMENT= Practical Extraction and Report Language
PERL_VER= 5.8.8
PERL_ARCH= mach
PERL_VERSION= ${PERL_VER}
+SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
+SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
USE_BZIP2= yes
HAS_CONFIGURE= yes
@@ -51,6 +53,11 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
.include "Makefile.man"
.include <bsd.port.pre.mk>
+PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ SITE_PERL=${SITE_PERL:S|^${LOCALBASE}/||}
+
.if defined(WITH_DEBUGGING)
CONFIGURE_ARGS+= -Doptimize="-g" -DDEBUGGING
STRIP=
diff --git a/lang/perl5.16/Makefile b/lang/perl5.16/Makefile
index 725f1b4d0b44..4ec9934273c7 100644
--- a/lang/perl5.16/Makefile
+++ b/lang/perl5.16/Makefile
@@ -26,6 +26,8 @@ COMMENT= Practical Extraction and Report Language
PERL_VER= 5.8.8
PERL_ARCH= mach
PERL_VERSION= ${PERL_VER}
+SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
+SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
USE_BZIP2= yes
HAS_CONFIGURE= yes
@@ -51,6 +53,11 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
.include "Makefile.man"
.include <bsd.port.pre.mk>
+PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ SITE_PERL=${SITE_PERL:S|^${LOCALBASE}/||}
+
.if defined(WITH_DEBUGGING)
CONFIGURE_ARGS+= -Doptimize="-g" -DDEBUGGING
STRIP=
diff --git a/lang/perl5.6/Makefile b/lang/perl5.6/Makefile
index 8e48d5aec941..1c9a50d93d6e 100644
--- a/lang/perl5.6/Makefile
+++ b/lang/perl5.6/Makefile
@@ -23,6 +23,8 @@ COMMENT= Practical Extraction and Report Language
PERL_VER= 5.6.2
PERL_ARCH= mach
PERL_VERSION= ${PERL_VER}
+SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
+SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT=Configure
@@ -47,6 +49,11 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
.include "Makefile.man"
.include <bsd.port.pre.mk>
+PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ SITE_PERL=${SITE_PERL:S|^${LOCALBASE}/||}
+
.if defined(ENABLE_SUIDPERL)
CONFIGURE_ARGS+= -Dd_dosuid=define
PLIST_SUB+= ENABLE_SUIDPERL=""
diff --git a/lang/perl5.8/Makefile b/lang/perl5.8/Makefile
index 725f1b4d0b44..4ec9934273c7 100644
--- a/lang/perl5.8/Makefile
+++ b/lang/perl5.8/Makefile
@@ -26,6 +26,8 @@ COMMENT= Practical Extraction and Report Language
PERL_VER= 5.8.8
PERL_ARCH= mach
PERL_VERSION= ${PERL_VER}
+SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
+SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
USE_BZIP2= yes
HAS_CONFIGURE= yes
@@ -51,6 +53,11 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
.include "Makefile.man"
.include <bsd.port.pre.mk>
+PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ SITE_PERL=${SITE_PERL:S|^${LOCALBASE}/||}
+
.if defined(WITH_DEBUGGING)
CONFIGURE_ARGS+= -Doptimize="-g" -DDEBUGGING
STRIP=
diff --git a/lang/perl5/Makefile b/lang/perl5/Makefile
index 8e48d5aec941..1c9a50d93d6e 100644
--- a/lang/perl5/Makefile
+++ b/lang/perl5/Makefile
@@ -23,6 +23,8 @@ COMMENT= Practical Extraction and Report Language
PERL_VER= 5.6.2
PERL_ARCH= mach
PERL_VERSION= ${PERL_VER}
+SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
+SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT=Configure
@@ -47,6 +49,11 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
.include "Makefile.man"
.include <bsd.port.pre.mk>
+PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ SITE_PERL=${SITE_PERL:S|^${LOCALBASE}/||}
+
.if defined(ENABLE_SUIDPERL)
CONFIGURE_ARGS+= -Dd_dosuid=define
PLIST_SUB+= ENABLE_SUIDPERL=""
diff --git a/lang/pike76/Makefile b/lang/pike76/Makefile
index 4a9180df980a..8b2c95350e20 100644
--- a/lang/pike76/Makefile
+++ b/lang/pike76/Makefile
@@ -94,13 +94,9 @@ BROKEN= Does not compile
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
.endif
-# Allow building Embeded perl when >= 5.6
-.if ${PERL_LEVEL} > 500600
+# Allow building Embedded Perl
CONFIGURE_ARGS+= --with-perl
USE_PERL5= YES
-.else
-CONFIGURE_ARGS+= --without-perl
-.endif
.if defined(WITHOUT_RELOCATABLE_DUMPED_MODULES)
CONFIGURE_ARGS+= --without-relocatable-dumped-modules