summaryrefslogtreecommitdiff
path: root/lang/ruby18
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2005-02-05 04:59:26 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2005-02-05 04:59:26 +0000
commit870baf2a9ac76ec39ea9fa066418657fb53ede54 (patch)
tree49251f8ea7663d5f4d431ea8b3f43c4eaf180b23 /lang/ruby18
parent- Update to bsd.java.mk 2.0 (diff)
The slippery pthread support for systems prior to 502102 has been
dropped and the lang/ruby16_r and lang/ruby18_r ports have been removed, since no one seems to appreciate the partially working solution. Good news is that the pthread support of lang/ruby18 is now enabled by default for newer systems, which means the ruby interpreter is linked with libpthread. This will allow threaded extension libraries to run and work properly on those systems. The --march=cputype flag is disabled because it gets ruby to malfunction and fail to build. I don't know if the problem is in libpthread or in gcc. (It really makes me wonder if they had actually tested before asking me to do this somewhat risky change ;-)
Diffstat (limited to 'lang/ruby18')
-rw-r--r--lang/ruby18/Makefile24
-rw-r--r--lang/ruby18/pkg-plist14
2 files changed, 24 insertions, 14 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index e1558869f663..5f82a9ac67df 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -1,13 +1,13 @@
-# New ports collection makefile for: ruby-devel
+# New ports collection makefile for: ruby18
# Date created: 6 May 2001
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
-PORTNAME= ruby${RUBY_R}
+PORTNAME= ruby
PORTVERSION= ${RUBY_PORTVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang ruby ipv6
MASTER_SITES= ${MASTER_SITE_RUBY}
MASTER_SITE_SUBDIR= ${MASTER_SITE_SUBDIR_RUBY}
@@ -58,6 +58,17 @@ MAN1= ${RUBY_NAME}.1
LATEST_LINK= ruby-devel
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502102
+RUBY_ENABLE_PTHREAD?= public demand
+.endif
+
+.if defined(RUBY_ENABLE_PTHREAD) && ${RUBY_ENABLE_PTHREAD} != "no"
+CONFIGURE_ARGS+= --enable-pthread
+
+# There seems to be a bug in either gcc or libpthread that gets
+# (mini)ruby to malfunction..
+CFLAGS:= ${CFLAGS:N-march=*}
+.endif
.if ${ARCH} == "ia64"
BROKEN= "Segfault during build on ia64"
@@ -70,7 +81,7 @@ CONFIGURE_ARGS+= --enable-ipv6
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
-MLINKS= ${RUBY_NAME}.1 ruby${RUBY_R}.1
+MLINKS= ${RUBY_NAME}.1 ruby.1
IF_DEFAULT= ""
.else
IF_DEFAULT= "@comment "
@@ -145,10 +156,9 @@ post-install:
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
# Link just installed "ruby" to "ruby18", etc.
- ${LN} -f ${RUBY_WITH_SUFFIX} ${RUBY_WITHOUT_SUFFIX}${RUBY_R}
- ${LN} -f ${PREFIX}/man/man1/${RUBY_NAME}.1 ${PREFIX}/man/man1/ruby${RUBY_R}.1
+ ${LN} -f ${RUBY_WITH_SUFFIX} ${RUBY_WITHOUT_SUFFIX}
for f in ${INSTALLED_SCRIPTS}; do \
- ${LN} -f $${f}${RUBY_SUFFIX} $${f}${RUBY_R}; \
+ ${LN} -f $${f}${RUBY_SUFFIX} $${f}; \
done
.endif
${LDCONFIG} -m ${PREFIX}/lib
diff --git a/lang/ruby18/pkg-plist b/lang/ruby18/pkg-plist
index 5714dd82573a..6c733438a53b 100644
--- a/lang/ruby18/pkg-plist
+++ b/lang/ruby18/pkg-plist
@@ -1,16 +1,16 @@
-%%IF_DEFAULT%%bin/erb%%RUBY_R%%
+%%IF_DEFAULT%%bin/erb
bin/erb%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/h2rb%%RUBY_R%%
+%%IF_DEFAULT%%bin/h2rb
bin/h2rb%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/irb%%RUBY_R%%
+%%IF_DEFAULT%%bin/irb
bin/irb%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/rdoc%%RUBY_R%%
+%%IF_DEFAULT%%bin/rdoc
bin/rdoc%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/ri%%RUBY_R%%
+%%IF_DEFAULT%%bin/ri
bin/ri%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/ruby%%RUBY_R%%
+%%IF_DEFAULT%%bin/ruby
bin/ruby%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/testrb%%RUBY_R%%
+%%IF_DEFAULT%%bin/testrb
bin/testrb%%RUBY_SUFFIX%%
lib/lib%%RUBY_NAME%%-static.a
lib/lib%%RUBY_NAME%%.so