summaryrefslogtreecommitdiff
path: root/lang/ruby16
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2005-02-05 04:59:26 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2005-02-05 04:59:26 +0000
commit870baf2a9ac76ec39ea9fa066418657fb53ede54 (patch)
tree49251f8ea7663d5f4d431ea8b3f43c4eaf180b23 /lang/ruby16
parent- Update to bsd.java.mk 2.0 (diff)
The slippery pthread support for systems prior to 502102 has been
dropped and the lang/ruby16_r and lang/ruby18_r ports have been removed, since no one seems to appreciate the partially working solution. Good news is that the pthread support of lang/ruby18 is now enabled by default for newer systems, which means the ruby interpreter is linked with libpthread. This will allow threaded extension libraries to run and work properly on those systems. The --march=cputype flag is disabled because it gets ruby to malfunction and fail to build. I don't know if the problem is in libpthread or in gcc. (It really makes me wonder if they had actually tested before asking me to do this somewhat risky change ;-)
Diffstat (limited to 'lang/ruby16')
-rw-r--r--lang/ruby16/Makefile9
-rw-r--r--lang/ruby16/pkg-plist4
2 files changed, 6 insertions, 7 deletions
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index 884e968e1b09..7212c8bb08ba 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTNAME= ruby${RUBY_R}
+PORTNAME= ruby
PORTVERSION= ${RUBY_PORTVERSION}
PORTREVISION= 1
CATEGORIES= lang ruby ipv6
@@ -68,7 +68,7 @@ CONFIGURE_ARGS+= --enable-ipv6
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
-MLINKS= ${RUBY_NAME}.1 ruby${RUBY_R}.1
+MLINKS= ${RUBY_NAME}.1 ruby.1
IF_DEFAULT= ""
.else
IF_DEFAULT= "@comment "
@@ -115,10 +115,9 @@ post-install:
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
# Link just installed "ruby" to "ruby16", etc.
- ${LN} -f ${RUBY_WITH_SUFFIX} ${RUBY_WITHOUT_SUFFIX}${RUBY_R}
- ${LN} -f ${PREFIX}/man/man1/${RUBY_NAME}.1 ${PREFIX}/man/man1/ruby${RUBY_R}.1
+ ${LN} -f ${RUBY_WITH_SUFFIX} ${RUBY_WITHOUT_SUFFIX}
for f in ${INSTALLED_SCRIPTS}; do \
- ${LN} -f $${f}${RUBY_SUFFIX} $${f}${RUBY_R}; \
+ ${LN} -f $${f}${RUBY_SUFFIX} $${f}; \
done
.endif
${LDCONFIG} -m ${PREFIX}/lib
diff --git a/lang/ruby16/pkg-plist b/lang/ruby16/pkg-plist
index ece180bb53e8..8035fbe8e051 100644
--- a/lang/ruby16/pkg-plist
+++ b/lang/ruby16/pkg-plist
@@ -1,6 +1,6 @@
-%%IF_DEFAULT%%bin/irb%%RUBY_R%%
+%%IF_DEFAULT%%bin/irb
bin/irb%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/ruby%%RUBY_R%%
+%%IF_DEFAULT%%bin/ruby
bin/ruby%%RUBY_SUFFIX%%
lib/lib%%RUBY_NAME%%.so
lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%