summaryrefslogtreecommitdiff
path: root/lang/ratfor/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2000-08-27 06:16:37 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2000-08-27 06:16:37 +0000
commit277f8e68fff20cbf5fd86c7b47df528d655d7551 (patch)
tree100a0a051098788413e8ac7d4bf86157f3833ca3 /lang/ratfor/Makefile
parentPKGNAMEPREFIX cleanup. This should allow chained PKGNAMEPREFIX'es. (diff)
The Ratfor FORTRAN pre-processor described in the "SOFTWARE TOOLS" book.
Diffstat (limited to '')
-rw-r--r--lang/ratfor/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/lang/ratfor/Makefile b/lang/ratfor/Makefile
new file mode 100644
index 000000000000..3976211b6bba
--- /dev/null
+++ b/lang/ratfor/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: ratfor
+# Date created: Sat Aug 26, 2000
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= ratfor
+PORTVERSION= 1985.06
+CATEGORIES= lang
+MASTER_SITES= http://sepwww.stanford.edu/sep/prof/
+DISTFILES= ratfor.shar.2 local.ratfor77.shar
+
+MAINTAINER= obrien@FreeBSD.org
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CAT}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= | ${SH}
+#USE_GMAKE= yes
+ALL_TARGET= all tests
+MAN1= ratfor.1
+
+post-patch:
+ @cd ${WRKSRC} ; ${PATCH} --quiet < testw.patch
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ratfor77 ${PREFIX}/bin
+ cd ${PREFIX}/bin ; ${LN} -sf ratfor77 ratfor
+ ${INSTALL_MAN} ${WRKSRC}/ratfor.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>