summaryrefslogtreecommitdiff
path: root/lang/qc--
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-05 00:56:32 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-05 00:56:32 +0000
commit752518241b31a6c5fcd3c4b88a4f346365bf1f97 (patch)
treeea69b77e74c39d7a481027c22656ded653f2f0c5 /lang/qc--
parentadd tipograf 0.4 (diff)
add qc-- 20031201
The Quick C-- Compiler PR: 59893
Diffstat (limited to 'lang/qc--')
-rw-r--r--lang/qc--/Makefile37
-rw-r--r--lang/qc--/distinfo1
-rw-r--r--lang/qc--/files/patch-camlburg:mkfile21
-rw-r--r--lang/qc--/files/patch-doc:mkfile15
-rw-r--r--lang/qc--/files/patch-interp:features.nw13
-rw-r--r--lang/qc--/files/patch-interp:mkfile11
-rw-r--r--lang/qc--/files/patch-src:mkfile15
-rw-r--r--lang/qc--/files/patch-tools:mkfile21
-rw-r--r--lang/qc--/pkg-descr12
-rw-r--r--lang/qc--/pkg-plist8
10 files changed, 154 insertions, 0 deletions
diff --git a/lang/qc--/Makefile b/lang/qc--/Makefile
new file mode 100644
index 000000000000..a8f7ddfb4652
--- /dev/null
+++ b/lang/qc--/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: qc--
+# Date created: Nov 10, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= qc--
+PORTVERSION= 20031201
+CATEGORIES= lang
+MASTER_SITES= http://www.cminusminus.org/rsync/dist/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= The Quick C-- Compiler
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ notangle:${PORTSDIR}/devel/noweb \
+ latex:${PORTSDIR}/print/teTeX \
+ mk:${PORTSDIR}/devel/mk \
+ gsed:${PORTSDIR}/textproc/gsed
+LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
+
+USE_PERL5_BUILD= yes
+HAS_CONFIGURE= yes
+
+MAN1= camlburg.1 camlburgfix.1 nofake.1 ocamlerror.1 \
+ qc--.1 qc--internals.1 qc--interp.1
+
+do-build:
+ @(cd ${WRKSRC} && mk timestamps && mk all.opt)
+
+do-install:
+ @(cd ${WRKSRC} && mk install.opt)
+
+.include <bsd.port.mk>
diff --git a/lang/qc--/distinfo b/lang/qc--/distinfo
new file mode 100644
index 000000000000..561888910cf1
--- /dev/null
+++ b/lang/qc--/distinfo
@@ -0,0 +1 @@
+MD5 (qc--20031201.tar.gz) = 4aba28a276ffbc220fb7ea8f15ca100f
diff --git a/lang/qc--/files/patch-camlburg:mkfile b/lang/qc--/files/patch-camlburg:mkfile
new file mode 100644
index 000000000000..6135505e3de3
--- /dev/null
+++ b/lang/qc--/files/patch-camlburg:mkfile
@@ -0,0 +1,21 @@
+--- camlburg/mkfile.orig Tue Dec 2 14:16:57 2003
++++ camlburg/mkfile Tue Dec 2 14:17:33 2003
+@@ -63,13 +63,13 @@
+ cp ocamlburgfix.1 $MANDIR/man1
+
+ install:V: all
+- install -D ocamlburg $install_bin/ocamlburg
+- install -D ocamlburgfix $install_bin/camlburgfix
+- install -m 644 -D ocamlburg.1 $install_man1/camlburg.1
+- install -m 644 -D ocamlburgfix.1 $install_man1/camlburgfix.1
++ install ocamlburg $install_bin/ocamlburg
++ install ocamlburgfix $install_bin/camlburgfix
++ install -m 644 ocamlburg.1 $install_man1/camlburg.1
++ install -m 644 ocamlburgfix.1 $install_man1/camlburgfix.1
+
+ install.opt:V: install all.opt
+- install -D -s ocamlburg.opt $install_bin/ocamlburg.opt
++ install -s ocamlburg.opt $install_bin/ocamlburg.opt
+
+ dvi:V: $DVI
+ html:V: $HTML
diff --git a/lang/qc--/files/patch-doc:mkfile b/lang/qc--/files/patch-doc:mkfile
new file mode 100644
index 000000000000..0f2574340791
--- /dev/null
+++ b/lang/qc--/files/patch-doc:mkfile
@@ -0,0 +1,15 @@
+--- doc/mkfile.orig Tue Dec 2 14:14:04 2003
++++ doc/mkfile Tue Dec 2 14:14:45 2003
+@@ -31,9 +31,9 @@
+ update.opt:V: update
+
+ install:V: man
+- install -m 644 -D qc--.1 $install_man1/qc--.1
+- install -m 644 -D qc--internals.1 $install_man1/qc--internals.1
+- install -m 644 -D qc--interp.1 $install_man1/qc--interp.1
++ install -m 644 qc--.1 $install_man1/qc--.1
++ install -m 644 qc--internals.1 $install_man1/qc--internals.1
++ install -m 644 qc--interp.1 $install_man1/qc--interp.1
+
+ install.opt:V: install
+
diff --git a/lang/qc--/files/patch-interp:features.nw b/lang/qc--/files/patch-interp:features.nw
new file mode 100644
index 000000000000..9a2887e6c68d
--- /dev/null
+++ b/lang/qc--/files/patch-interp:features.nw
@@ -0,0 +1,13 @@
+--- interp/features.nw.orig Fri Sep 6 04:01:44 2002
++++ interp/features.nw Mon Nov 10 16:46:33 2003
+@@ -119,8 +119,8 @@
+ #ifndef _FLOAT_FEATURES_H
+ #define _FLOAT_FEATURES_H
+
+-#include <fenv.h>
+-#pragma STDC FENV_ACCESS ON
++/* #include <fenv.h> */
++/* #pragma STDC FENV_ACCESS ON */
+
+ #endif /* _FLOAT_FEATURES_H */
+ @
diff --git a/lang/qc--/files/patch-interp:mkfile b/lang/qc--/files/patch-interp:mkfile
new file mode 100644
index 000000000000..637fb69268ba
--- /dev/null
+++ b/lang/qc--/files/patch-interp:mkfile
@@ -0,0 +1,11 @@
+--- interp/mkfile.orig Mon Nov 10 13:39:30 2003
++++ interp/mkfile Mon Nov 10 13:39:39 2003
+@@ -359,7 +359,7 @@
+ $NOTANGLE -R$target $prereq > $target
+
+ inspect.clua:D: inspect.lua
+- sed -e 's/\\/\\\\/g' \
++ gsed -e 's/\\/\\\\/g' \
+ -e 's/"/\\"/g' \
+ -e 'i \' \
+ -e '\"\\' \
diff --git a/lang/qc--/files/patch-src:mkfile b/lang/qc--/files/patch-src:mkfile
new file mode 100644
index 000000000000..f38532768860
--- /dev/null
+++ b/lang/qc--/files/patch-src:mkfile
@@ -0,0 +1,15 @@
+--- src/mkfile.orig Tue Dec 2 14:27:06 2003
++++ src/mkfile Tue Dec 2 14:27:22 2003
+@@ -61,10 +61,10 @@
+ update.opt:V: $BINDIR/$NAME.opt
+
+ install:V: all
+- install -D $NAME $install_bin/$NAME
++ install $NAME $install_bin/$NAME
+
+ install.opt:V: install all.opt
+- install -D -s $NAME.opt $install_bin/$NAME.opt
++ install -s $NAME.opt $install_bin/$NAME.opt
+
+ depend:V: $DEPEND
+
diff --git a/lang/qc--/files/patch-tools:mkfile b/lang/qc--/files/patch-tools:mkfile
new file mode 100644
index 000000000000..cc8ada47aaaf
--- /dev/null
+++ b/lang/qc--/files/patch-tools:mkfile
@@ -0,0 +1,21 @@
+--- tools/mkfile.orig Tue Dec 2 14:15:05 2003
++++ tools/mkfile Tue Dec 2 14:15:52 2003
+@@ -47,13 +47,13 @@
+ cp newer $BINDIR
+
+ install:V: all
+- install -D ocamlerror $install_bin/ocamlerror
+- install -m 644 -D ocamlerror.1 $install_man1/ocamlerror.1
+- install -D nofake $install_bin/nofake
+- install -m 644 -D nofake.1 $install_man1/nofake.1
++ install ocamlerror $install_bin/ocamlerror
++ install -m 644 ocamlerror.1 $install_man1/ocamlerror.1
++ install nofake $install_bin/nofake
++ install -m 644 nofake.1 $install_man1/nofake.1
+
+ install.opt:V: install all
+- install -D -s ocamlerror.opt $install_bin/ocamlerror.opt
++ install -s ocamlerror.opt $install_bin/ocamlerror.opt
+
+ dvi:V: $INC
+ html:V: $HTML
diff --git a/lang/qc--/pkg-descr b/lang/qc--/pkg-descr
new file mode 100644
index 000000000000..ae484d131377
--- /dev/null
+++ b/lang/qc--/pkg-descr
@@ -0,0 +1,12 @@
+C-- is intended as a "portable assembly language" that can replace C as a
+target language used by compiler writers. The goal of the Quick C-- project is
+to test those ideas in an implementation. Quick C-- is intended to be a simple,
+nonoptimizing compiler that supports the run-time interface. Our primary goal
+is to to validate our design experimentally. A secondary, but still significant
+goal is to provide a vehicle for experimenting with new techniques for building
+retargetable compilers. We want the compiler to be
+ 1. Easy to retarget to the platform of choice
+ 2. Easy to specialize, say for a new calling convention
+ 3. Fast
+
+WWW: http://www.cminusminus.org/qc--.html
diff --git a/lang/qc--/pkg-plist b/lang/qc--/pkg-plist
new file mode 100644
index 000000000000..6d44f5d7b5d2
--- /dev/null
+++ b/lang/qc--/pkg-plist
@@ -0,0 +1,8 @@
+bin/camlburgfix
+bin/nofake
+bin/ocamlburg
+bin/ocamlburg.opt
+bin/ocamlerror
+bin/ocamlerror.opt
+bin/qc--
+bin/qc--.opt