summaryrefslogtreecommitdiff
path: root/lang/python32
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-12-29 12:03:09 +0000
committerJohn Marino <marino@FreeBSD.org>2015-12-29 12:03:09 +0000
commit6256117d69833c86052b33bbc7252a244d3413a7 (patch)
tree442cd87d41f98356b818e916797bd629171b005c /lang/python32
parentFind Postfix also if installed with INST_BASE option. (diff)
lang/python27(3*), Mk/Uses/python.mk: remove make spawn
There are some inefficiencies in python.mk that significantly slow down full tree scanning. The use of bmake to obtain the current version of a specific python is responsible for the majority of the slow done. This commit splits out the PYTHON_PORTVERSION definition (which is the same as the lang/python* PORTVERSION) into separate files. With this change, python.mk can simple include the makefile fragment instead of spawning a new instance of make. Different Revision: https://reviews.freebsd.org/D4660 Approved by: antoine (python), mva (python)
Diffstat (limited to '')
-rw-r--r--lang/python32/Makefile3
-rw-r--r--lang/python32/Makefile.version4
2 files changed, 6 insertions, 1 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 8db7f8ed4e89..43f045754cb2 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= python32
-PORTVERSION= 3.2.6
+PORTVERSION= ${PYTHON_PORTVERSION}
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -71,6 +71,7 @@ THREADS_LDFLAGS= -lpthread
TSC_CONFIGURE_WITH= tsc
UCS4_CONFIGURE_WITH= wide-unicode
+.include "${.CURDIR}/Makefile.version"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MUCS4}
diff --git a/lang/python32/Makefile.version b/lang/python32/Makefile.version
new file mode 100644
index 000000000000..681b086322df
--- /dev/null
+++ b/lang/python32/Makefile.version
@@ -0,0 +1,4 @@
+# Mk/Uses/python.mk includes this file, don't remove it!
+# $FreeBSD$
+
+PYTHON_PORTVERSION= 3.2.6