summaryrefslogtreecommitdiff
path: root/lang/python32/files/patch-Makefile.pre.in
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-04-22 12:14:26 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-04-22 12:14:26 +0000
commitaab3da8d2a0a8217ca1350b9d140834e2c7ed0ad (patch)
tree2226051bf99bde369767be57f56156ee325743e8 /lang/python32/files/patch-Makefile.pre.in
parentSupport stage (diff)
lang/python{31,32,33}: Fix stage/package as non-root
Copy the second part of a change previously made to python27 [1], to python31, python32 and python33. This fixes staging and packaging of these ports by a non-root user by running ranlib on the archive prior to it being installed read-only. While I'm here: - python27: Add breadcrumbs and references to the patch header - python34: Update breadcrumbs and references to the patch header [1] https://svnweb.freebsd.org/ports?view=revision&revision=350207 Submitted by: antoine Reviewed by: kwm, sbz
Diffstat (limited to '')
-rw-r--r--lang/python32/files/patch-Makefile.pre.in26
1 files changed, 24 insertions, 2 deletions
diff --git a/lang/python32/files/patch-Makefile.pre.in b/lang/python32/files/patch-Makefile.pre.in
index 997211fbf9a8..60c15542e123 100644
--- a/lang/python32/files/patch-Makefile.pre.in
+++ b/lang/python32/files/patch-Makefile.pre.in
@@ -1,5 +1,17 @@
---- Makefile.pre.in.orig 2013-05-16 02:33:51.000000000 +1000
-+++ Makefile.pre.in 2013-09-05 23:42:32.910025692 +1000
+# Description: Remove duplicate CFLAGS, CPPFLAGS, LDFLAGS by stripping CONFIGURE_*
+# Submitted by: koobs (r326729)
+# TODO: Upstream
+
+# Description: Fix out-of-tree build as a result of upstream #15819
+# Submitted by: rm (r318353)
+# Issue ID: http://bugs.python.org/issue15819#msg203348
+
+# Description: Run ranlib before installing the library read-only
+# Submitted by: antoine@ (r350207)
+# TODO: Upstream
+
+--- ./Makefile.pre.in.orig 2013-05-16 02:33:51.000000000 +1000
++++ ./Makefile.pre.in 2014-04-20 23:27:06.346079817 +1000
@@ -70,18 +70,18 @@
OPT= @OPT@
BASECFLAGS= @BASECFLAGS@
@@ -69,3 +81,13 @@
############################################################################
# Header files
+@@ -1108,8 +1108,8 @@
+ if test "$(SHLIB_SUFFIX)" = .dll; then \
+ $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
+ else \
++ $(RANLIB) $(LIBRARY) ; \
+ $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+ fi; \
+ else \
+ echo Skip install of $(LIBRARY) - use make frameworkinstall; \