summaryrefslogtreecommitdiff
path: root/lang/python32/Makefile
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2006-10-13 07:16:45 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2006-10-13 07:16:45 +0000
commite18b838fd903ca4a6c3dca6db8a75eedefd645e4 (patch)
tree984ef244bb83f4a2bfc290e7cc31fd2928e81ef0 /lang/python32/Makefile
parent- Add a forgotten man page and fix deinstall (diff)
Revert the default version of Python to 2.4 for the ports freeze
period. Python 2.5 brought a vast range of incompatibility to a large number of ports, so the python@ team will do more basic compatibility work in a private repository and merge it later. Sorry for the inconvenience. Approved by: portmgr (kris)
Diffstat (limited to '')
-rw-r--r--lang/python32/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 04f73a152081..33f5cff93183 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python25
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -23,13 +24,12 @@ CONFIGURE_SCRIPT= ../configure # must be relative
CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
INSTALLS_SHLIB= yes
-INSTALL_TARGET= install
-MAN1= python.1 ${PYTHON_VERSION}.1
+INSTALL_TARGET= altinstall
+MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
PYTHON_VERSION= python2.5
PYTHON_NO_DEPENDS= yes
-LATEST_LINK= ${PYTHON_VERSION:S/.//}
SHARED_WRKSRC= ${PYTHON_WRKSRC}/portbld.shared
PLIST= ${WRKDIR}/PLIST
@@ -203,10 +203,6 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
- cd ${PREFIX}/bin; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/} python-shared; \
- ${LN} -f ${PYTHON_VERSION:S/thon/thon-shared/}-config \
- python-shared-config; \
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.5 ${WRKDIR}/idle2.5 \