summaryrefslogtreecommitdiff
path: root/lang/python32/Makefile
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2006-08-10 10:05:13 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2006-08-10 10:05:13 +0000
commitdf0b95301ad1855a5e560611ee09667a4cc3f8b9 (patch)
tree2d5e949e1e51d87d90e94f98cd40f1e5dae51a62 /lang/python32/Makefile
parent- Ferret is a high-performance, full-featured text search engine library writ... (diff)
Fix plist for FreeBSD 7 or systems with OpenSSL 0.9.8.
Spotted by: pointyhat via kris
Diffstat (limited to '')
-rw-r--r--lang/python32/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index c5e43121fc0c..5fe7a8741968 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -174,6 +174,11 @@ pre-install:
/LIBDIR.*\.py$$/ && !/\/bad/ { print $$0 "o"; print $$0 "c"; }' \
${PLIST_TEMPLATE} > ${PLIST}
+ @# if openssl 0.9.8 is detected, _sha{256,512} module won't be installed
+ ([ -f ${WRKSRC}/.without_own_sha ] && \
+ ${GREP} -v 'lib-dynload/_sha' ${PLIST} > ${PLIST}.tmp && \
+ ${CAT} ${PLIST}.tmp > ${PLIST}) || ${TRUE}
+
post-install:
@# install config providers
${INSTALL_SCRIPT} ${WRKDIR}/${PYTHON_VERSION}-config ${PREFIX}/bin