summaryrefslogtreecommitdiff
path: root/lang/python32/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-09-18 08:33:15 +0000
committerChris Rees <crees@FreeBSD.org>2011-09-18 08:33:15 +0000
commitd03cd9afc5c493cefcf8dc87de3689b53d79a54d (patch)
tree1eb7a0391e3b616f786f85392504dc00fc02c250 /lang/python32/Makefile
parent- Update to 2.2. This is a bugfix release; it also adds support for (diff)
Handle built world without NIS more gracefully; detect missing ypcat and
disable NIS module. PR: ports/115940 Submitted by: Alex Deiter <tiamat@komi.mts.ru> Reviewed by: bf
Diffstat (limited to '')
-rw-r--r--lang/python32/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index fa283d2a72ff..5fc533074b86 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -100,8 +100,10 @@ PYABIVER:= m${PYABIVER}
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-.if !exists(/usr/bin/ypcat) # the world with NO_NIS
+# See http://bugs.freebsd.org/115940
+.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
PLIST_SUB+= NO_NIS="@comment "
+WITHOUT_NIS?= detected
.else
PLIST_SUB+= NO_NIS=""
.endif
@@ -147,6 +149,13 @@ pre-patch:
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
+post-patch:
+.if defined(WITHOUT_NIS)
+ ${REINPLACE_CMD} -e \
+ 's/disabled_module_list =[^]]*/&, "nis"/' \
+ ${PATCH_WRKSRC}/setup.py
+.endif
+
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -
${LN} -sf ${PYTHON_WRKSRC}/Lib ${WRKSRC}/Lib