summaryrefslogtreecommitdiff
path: root/lang/python32/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-26 12:44:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-26 12:44:47 +0000
commit5879a953cb0ac86557ca9fc62713bfeb193ce369 (patch)
tree676c282b5191b5628fb265f378e2eb41f32ba0fe /lang/python32/Makefile
parentUse correct type for storing timestamps. (diff)
- Add support for FreeBSD 9
Diffstat (limited to '')
-rw-r--r--lang/python32/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 058c9c9e431a..44a2a2efc5b7 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python31
PORTVERSION= 3.1.1
+PORTREVISON= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -39,7 +40,7 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
DATADIR= ${PREFIX}/share/${PYTHON_VERSION}
PLATFORMS= plat-freebsd4 plat-freebsd5 plat-freebsd6 \
- plat-freebsd7 plat-freebsd8
+ plat-freebsd7 plat-freebsd8 plat-freebsd9
BIN_SCRIPTS= 2to3 idle3 pydoc3
BIN_FILES= python python-shared python-config python-shared-config \
@@ -111,6 +112,8 @@ CONFIGURE_ARGS+= --with-fpectl
.endif
pre-patch:
+ ${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
+ ${PATCH_WRKSRC}/Lib/plat-freebsd9
${MKDIR} ${WRKSRC} ${SHARED_WRKSRC}/Modules
.for script in ${BIN_SCRIPTS}
${SED} -e '1s,^.*$$,#!${PREFIX}/bin/${PYTHON_VERSION},' \