summaryrefslogtreecommitdiff
path: root/lang/python27/files/patch-setup.py
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-10-29 21:31:13 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-10-29 21:31:13 +0000
commit040577c1f708795f24bc28e7ccae630dacc0e76b (patch)
tree79cc960dfc84613c3f0efb0fb08fe4297a2575ca /lang/python27/files/patch-setup.py
parent- Update to version 1.10 (diff)
- Update lang/python-devel to Python-2.4 031022 snapshot.
- Correct USE_ZOPE dependency to Python 2.1. [1] - Fetch from correct MASTER_SITE_SUBDIR when upgrading python in same branch. [2] - Enable installing separated standard modules for python-devel port. Reported by: Filippo Natali <pitonat@libero.it> [1], Yoshihiko Sarumaru <mistral@imasy.or.jp> [2]
Diffstat (limited to 'lang/python27/files/patch-setup.py')
-rw-r--r--lang/python27/files/patch-setup.py15
1 files changed, 12 insertions, 3 deletions
diff --git a/lang/python27/files/patch-setup.py b/lang/python27/files/patch-setup.py
index 63779f7d0fe0..d83025329ce0 100644
--- a/lang/python27/files/patch-setup.py
+++ b/lang/python27/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Thu Jul 10 21:48:39 2003
-+++ setup.py Sat Jul 19 16:27:04 2003
+--- setup.py.orig Wed Oct 22 00:41:15 2003
++++ setup.py Thu Oct 30 06:21:21 2003
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,7 +9,16 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -1128,7 +1128,7 @@
+@@ -770,7 +770,7 @@
+ # Linux-specific modules
+ exts.append( Extension('linuxaudiodev', ['linuxaudiodev.c']) )
+
+- if platform in ('linux2', 'freebsd4'):
++ if platform in ('linux2', 'freebsd4', 'freebsd5'):
+ exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
+
+ if platform == 'sunos5':
+@@ -1140,7 +1140,7 @@
ext_modules=[Extension('struct', ['structmodule.c'])],
# Scripts to install