summaryrefslogtreecommitdiff
path: root/lang/python21/files
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-07-04 11:57:54 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-07-04 11:57:54 +0000
commit6b9a7cf7782f06f68fe0bb60c29e0314090478a8 (patch)
tree787099ac1b8b1735392abd6c18e7d8fe5d86ac0d /lang/python21/files
parentEnable full javadoc build. (diff)
o Utilize MASTER_SITE_PYTHON.
o Rename pydoc to pydoc${PORTVERSION} to avoid conflicts among these ports. (lang/python port keeps both of bin/pydoc and bin/pydoc2.2) o Set LATEST_LINK to ${PYTHON_VERSION:S/.//} except lang/python. Now, we can install all of these python versions together cleanly.
Diffstat (limited to 'lang/python21/files')
-rw-r--r--lang/python21/files/patch-setup.py13
1 files changed, 11 insertions, 2 deletions
diff --git a/lang/python21/files/patch-setup.py b/lang/python21/files/patch-setup.py
index f3cef489fa8f..a2ea5569ba4f 100644
--- a/lang/python21/files/patch-setup.py
+++ b/lang/python21/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Fri Mar 2 07:24:14 2001
-+++ setup.py Mon Mar 5 15:26:17 2001
+--- setup.py.orig Fri Dec 28 06:51:02 2001
++++ setup.py Fri Jul 4 18:38:23 2003
@@ -14,7 +14,7 @@
from distutils.command.build_ext import build_ext
@@ -9,3 +9,12 @@
def find_file(filename, std_dirs, paths):
"""Searches for the directory where a given file is located,
+@@ -609,7 +609,7 @@
+ ext_modules=[Extension('struct', ['structmodule.c'])],
+
+ # Scripts to install
+- scripts = ['Tools/scripts/pydoc']
++ scripts = []
+ )
+
+ # --install-platlib