summaryrefslogtreecommitdiff
path: root/lang/python21/Makefile
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-07-04 11:57:54 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-07-04 11:57:54 +0000
commit6b9a7cf7782f06f68fe0bb60c29e0314090478a8 (patch)
tree787099ac1b8b1735392abd6c18e7d8fe5d86ac0d /lang/python21/Makefile
parentEnable full javadoc build. (diff)
o Utilize MASTER_SITE_PYTHON.
o Rename pydoc to pydoc${PORTVERSION} to avoid conflicts among these ports. (lang/python port keeps both of bin/pydoc and bin/pydoc2.2) o Set LATEST_LINK to ${PYTHON_VERSION:S/.//} except lang/python. Now, we can install all of these python versions together cleanly.
Diffstat (limited to 'lang/python21/Makefile')
-rw-r--r--lang/python21/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/lang/python21/Makefile b/lang/python21/Makefile
index f4d18d7db204..58278e42f66c 100644
--- a/lang/python21/Makefile
+++ b/lang/python21/Makefile
@@ -7,12 +7,10 @@
PORTNAME= python
PORTVERSION= 2.1.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang python
-MASTER_SITES= http://www.python.org/ftp/python/${PORTVERSION}/ \
- ${MASTER_SITE_SOURCEFORGE} \
- http://SunSITE.Informatik.RWTH-Aachen.DE/python/ftp/python/${PORTVERSION}/
-MASTER_SITE_SUBDIR= python
+MASTER_SITES= ${MASTER_SITE_PYTHON}
+MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
DISTFILES= ${PYTHON_DISTFILE}
MAINTAINER= perky@FreeBSD.org
@@ -29,6 +27,7 @@ MAN1= ${PYTHON_VERSION}.1
USE_PYTHON= yes
PYTHON_VERSION= python2.1
PYTHON_NO_DEPENDS= yes
+LATEST_LINK= ${PYTHON_VERSION:S/.//}
#
# If you don't want to use Python's thread module, you need to set
@@ -70,6 +69,10 @@ PLATFORMS=plat-freebsd2 plat-freebsd4 plat-freebsd5
PLATFORMS=plat-freebsd3 plat-freebsd4 plat-freebsd5
.endif
+post-extract:
+ ${SED} -e '1s,^.*$$,#!${PREFIX}/bin/${PYTHON_VERSION},' \
+ ${WRKSRC}/Tools/scripts/pydoc > ${WRKDIR}/pydoc2.1
+
pre-install:
.for platform in ${PLATFORMS}
${MKDIR} ${PYTHONPREFIX_LIBDIR}/${platform}
@@ -80,6 +83,7 @@ pre-install:
.endfor
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.1 ${PREFIX}/bin
@${MKDIR} ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/Misc/python.man \
${MANPREFIX}/man/man1/${PYTHON_VERSION}.1