summaryrefslogtreecommitdiff
path: root/lang/pm3-forms/Makefile
diff options
context:
space:
mode:
authorJohn Polstra <jdp@FreeBSD.org>2000-02-10 05:46:18 +0000
committerJohn Polstra <jdp@FreeBSD.org>2000-02-10 05:46:18 +0000
commit76acab505b23478fbcfcd9beaa66e37d2cff99a3 (patch)
treef4ad65498b7f9d7ce01c040678e1f9965a5159cb /lang/pm3-forms/Makefile
parentAdd the xmms-mikmod port. (diff)
Add four new ports for various portions of the Polytechnique
Montreal Modula-3 (PM3) distribution. This is the most actively maintained Modula-3 distribution, and I will probably make CVSup use it soon. These ports work for FreeBSD 2.x, 3.x, and 4.x on the i386, and FreeBSD 4.x on the Alpha.
Diffstat (limited to 'lang/pm3-forms/Makefile')
-rw-r--r--lang/pm3-forms/Makefile79
1 files changed, 79 insertions, 0 deletions
diff --git a/lang/pm3-forms/Makefile b/lang/pm3-forms/Makefile
new file mode 100644
index 000000000000..131d81e498f9
--- /dev/null
+++ b/lang/pm3-forms/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: pm3-forms
+# Version required: 1.1.13
+# Date created: 6 Feb 2000
+# Whom: John Polstra <jdp@freebsd.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= pm3-forms-${VERSION}
+CATEGORIES= lang
+DISTFILES=
+
+MAINTAINER= jdp@freebsd.org
+
+BUILD_DEPENDS= ${PREFIX}/lib/m3/${TARGET}/libm3vbtkit.so.${SOVERSION}:${PORTSDIR}/lang/pm3-gui
+RUN_DEPENDS= ${PREFIX}/lib/m3/${TARGET}/libm3vbtkit.so.${SOVERSION}:${PORTSDIR}/lang/pm3-gui
+DEPENDS= ${PORTSDIR}/lang/pm3-base:configure
+
+DIST_SUBDIR= pm3
+INSTALL_TARGET= all
+MAN1= formsedit.1
+PLIST_SUB+= SOVERSION=${SOVERSION} TARGET=${TARGET} \
+ TARGETDIR=${TARGETDIR} WORDSIZE=${WORDSIZE}
+WRKSRC= ${WRKDIRPREFIX}${.CURDIR}/../pm3-base/work/pm3-${VERSION}
+
+BUILDDIRS= network/www/web \
+ graphics/gr-libs/jvideo \
+ graphics/gr-libs/videovbt \
+ graphics/forms/formsvbtpixmaps \
+ graphics/forms/formsvbt \
+ graphics/forms/formsedit
+PROGS= bin/formsedit
+SOVERSION= 7
+VERSION= 1.1.13
+
+.include <bsd.port.pre.mk>
+
+.if ${PORTOBJFORMAT} == "aout"
+TARGET= FreeBSD2
+TARGETDIR= freebsd-2
+WORDSIZE= 32
+.elif ${ARCH} == "i386"
+.if ${OSVERSION} < 400011
+TARGET= FreeBSD3
+TARGETDIR= freebsd-3
+.else
+TARGET= FreeBSD4
+TARGETDIR= freebsd-4
+.endif
+WORDSIZE= 32
+.elif ${ARCH} == "alpha"
+.if ${OSVERSION} < 400011
+BROKEN= Not supported on older versions of FreeBSD/Alpha
+.endif
+CFLAGS+= -mieee
+TARGET= FBSD_ALPHA
+TARGETDIR= fbsd-alpha
+WORDSIZE= 64
+.endif
+
+.if empty(TARGET)
+pre-fetch:
+ @${ECHO_MSG} "Cannot determine M3 target for this architecture"
+ @${FALSE}
+.endif
+
+do-build:
+ @${ECHO_MSG} "This port does everything in the install step."
+ @${ECHO_MSG} "The build step is a no-op."
+
+do-install:
+ @for i in ${BUILDDIRS}; do \
+ ${ECHO_MSG} "Building in $${i}"; \
+ cd ${WRKSRC}/$${i} && ${PREFIX}/bin/m3build && \
+ ${PREFIX}/bin/m3ship; \
+ done
+ @for i in ${PROGS}; do strip ${PREFIX}/$$i; done
+
+.include <bsd.port.post.mk>