summaryrefslogtreecommitdiff
path: root/lang/php5/files
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-05-22 18:26:28 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-05-22 18:26:28 +0000
commit18ea1afefe75baf9e9d5a81ea4e2820433993faa (patch)
tree1edc7b7cce0659feb4e86a0fdd1cd78d96db73ef /lang/php5/files
parentChase the distfile; update MASTER_SITES. (diff)
Add completely new port system for PHP4 (4.3.2RC4). Updated mod_php4
to 4.3.2RC4 release and added php4-cli and php4 ports, for apache module, command line interface, and both, respectively. Too many changes (improvements, bug fixes and new features) to be listed here, PR: ports/51945 Submitted by: Alex Dupre <sysadmin@alexdupre.com>
Diffstat (limited to 'lang/php5/files')
-rw-r--r--lang/php5/files/patch-configure136
-rw-r--r--lang/php5/files/patch-pear::Makefile.frag22
-rw-r--r--lang/php5/files/patch-pear::scripts::pearcmd.php18
3 files changed, 176 insertions, 0 deletions
diff --git a/lang/php5/files/patch-configure b/lang/php5/files/patch-configure
new file mode 100644
index 000000000000..eda6b0e7209a
--- /dev/null
+++ b/lang/php5/files/patch-configure
@@ -0,0 +1,136 @@
+--- configure.orig Thu May 1 23:30:59 2003
++++ configure Fri May 2 15:59:58 2003
+@@ -70925,29 +70925,6 @@
+ else
+
+
+- case cs in
+- c|c_r|pthread*) ;;
+- *)
+- if test "$ext_shared" = "yes"; then
+- SYBASE_CT_SHARED_LIBADD="-lcs $SYBASE_CT_SHARED_LIBADD"
+- else
+-
+-
+- case cs in
+- c|c_r|pthread*) ;;
+- *)
+- LIBS="-lcs $LIBS"
+- ;;
+- esac
+-
+-
+- fi
+- ;;
+- esac
+-
+-
+-
+-
+ case ct in
+ c|c_r|pthread*) ;;
+ *)
+@@ -70971,52 +70948,7 @@
+
+
+
+- case comn in
+- c|c_r|pthread*) ;;
+- *)
+- if test "$ext_shared" = "yes"; then
+- SYBASE_CT_SHARED_LIBADD="-lcomn $SYBASE_CT_SHARED_LIBADD"
+- else
+-
+-
+- case comn in
+- c|c_r|pthread*) ;;
+- *)
+- LIBS="-lcomn $LIBS"
+- ;;
+- esac
+-
+-
+- fi
+- ;;
+- esac
+-
+-
+-
+-
+- case intl in
+- c|c_r|pthread*) ;;
+- *)
+- if test "$ext_shared" = "yes"; then
+- SYBASE_CT_SHARED_LIBADD="-lintl $SYBASE_CT_SHARED_LIBADD"
+- else
+-
+-
+- case intl in
+- c|c_r|pthread*) ;;
+- *)
+- LIBS="-lintl $LIBS"
+- ;;
+- esac
+-
+-
+- fi
+- ;;
+- esac
+-
+-
+-
+- SYBASE_CT_LIBS="-L$SYBASE_CT_LIBDIR -lcs -lct -lcomn -lintl"
++ SYBASE_CT_LIBS="-L$SYBASE_CT_LIBDIR -lct"
+
+
+ save_old_LDFLAGS=$LDFLAGS
+@@ -71086,37 +71018,6 @@
+
+
+
+-else
+- echo "$ac_t""no" 1>&6
+-
+- LDFLAGS=$save_old_LDFLAGS
+- unset ac_cv_func_tcl
+-
+-
+-
+- case sybtcl in
+- c|c_r|pthread*) ;;
+- *)
+- if test "$ext_shared" = "yes"; then
+- SYBASE_CT_SHARED_LIBADD="-lsybtcl $SYBASE_CT_SHARED_LIBADD"
+- else
+-
+-
+- case sybtcl in
+- c|c_r|pthread*) ;;
+- *)
+- LIBS="-lsybtcl $LIBS"
+- ;;
+- esac
+-
+-
+- fi
+- ;;
+- esac
+-
+-
+-
+-
+ fi
+
+
+@@ -84050,10 +83951,7 @@
+ CXXFLAGS="$CXXFLAGS $standard_libtool_flag"
+
+ all_targets='$(OVERALL_TARGET) $(PHP_MODULES) $(PHP_CLI_TARGET)'
+-install_targets="install-sapi install-modules $install_pear install-build install-headers install-programs"
+-if test "$PHP_SAPI" != "cgi"; then
+- install_targets="$PHP_INSTALL_CLI_TARGET $install_targets"
+-fi
++install_targets="install-sapi $PHP_INSTALL_CLI_TARGET install-modules $install_pear install-build install-headers install-programs"
+
+
+ PHP_VAR_SUBST="$PHP_VAR_SUBST all_targets"
diff --git a/lang/php5/files/patch-pear::Makefile.frag b/lang/php5/files/patch-pear::Makefile.frag
new file mode 100644
index 000000000000..6653c7852f69
--- /dev/null
+++ b/lang/php5/files/patch-pear::Makefile.frag
@@ -0,0 +1,22 @@
+--- pear/Makefile.frag.orig Sat Apr 12 01:48:37 2003
++++ pear/Makefile.frag Sat May 17 10:08:54 2003
+@@ -13,10 +13,13 @@
+
+ install-pear:
+ @echo "Installing PEAR environment: $(INSTALL_ROOT)$(peardir)/"
+- @if $(mkinstalldirs) $(INSTALL_ROOT)$(peardir); then \
+- $(MAKE) -s install-pear-installer install-pear-packages; \
+- else \
+- cat $(srcdir)/install-pear.txt; \
+- exit 5; \
+- fi
++ @$(mkinstalldirs) $(INSTALL_ROOT)$(peardir)/bootstrap \
++ $(INSTALL_ROOT)$(peardir)/bootstrap/Archive \
++ $(INSTALL_ROOT)$(peardir)/bootstrap/Console
++ @cp $(srcdir)/PEAR.php $(srcdir)/System.php \
++ $(INSTALL_ROOT)$(peardir)/bootstrap
++ @cp $(srcdir)/Archive/*.php $(INSTALL_ROOT)$(peardir)/bootstrap/Archive
++ @cp $(srcdir)/Console/*.php $(INSTALL_ROOT)$(peardir)/bootstrap/Console
++ @cp -R $(srcdir)/OS $(INSTALL_ROOT)$(peardir)/bootstrap/OS
++ @cp -R $(srcdir)/PEAR $(INSTALL_ROOT)$(peardir)/bootstrap/PEAR
+
diff --git a/lang/php5/files/patch-pear::scripts::pearcmd.php b/lang/php5/files/patch-pear::scripts::pearcmd.php
new file mode 100644
index 000000000000..642fc7e118a1
--- /dev/null
+++ b/lang/php5/files/patch-pear::scripts::pearcmd.php
@@ -0,0 +1,18 @@
+--- pear/scripts/pearcmd.php.orig Fri May 16 17:31:37 2003
++++ pear/scripts/pearcmd.php Fri May 16 17:36:10 2003
+@@ -1,3 +1,4 @@
++#!%%PREFIX%%/bin/php -n -dsafe_mode=0 -doutput_buffering=1
+ <?php
+ //
+ // +----------------------------------------------------------------------+
+@@ -24,9 +25,7 @@
+ /**
+ * @nodep Gtk
+ */
+-if ('@include_path@' != '@'.'include_path'.'@') {
+- ini_set('include_path', '@include_path@');
+-}
++ini_set('include_path', '%%PREFIX%%/share/pear:%%PREFIX%%/share/pear/bootstrap');
+ ini_set('allow_url_fopen', true);
+ set_time_limit(0);
+ ob_implicit_flush(true);