summaryrefslogtreecommitdiff
path: root/lang/php4
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-01-30 09:59:33 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-01-30 09:59:33 +0000
commit11c36a558fd7d825d638c5d476e334bf936ceb5a (patch)
treea7d89c275eaa9b67a7300469a64fe0897eb57d14 /lang/php4
parentFORBIDDEN: Creates /almost-certainly-does-not-exist in the root dir (diff)
Add workaround to silent bento, complaining php extensions remove an extra dir.
Reported by: bento via kris Approved by: kris, nork (mentor/implicitly)
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile1
-rw-r--r--lang/php4/pkg-plist2
2 files changed, 2 insertions, 1 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 2a3f9579de14..705f40986962 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -705,6 +705,7 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/php.ini-dist ${PREFIX}/etc
@${INSTALL_DATA} ${WRKSRC}/php.ini-recommended ${PREFIX}/etc
@${INSTALL_DATA} ${WRKDIR}/php.conf ${PREFIX}/etc
+ @${TOUCH} ${PREFIX}/lib/php/${EXT_DIR}/.keepme
.if !defined(WITHOUT_APACHE)
@${ECHO_CMD} "*****************************************************************************"
@${ECHO_CMD} ""
diff --git a/lang/php4/pkg-plist b/lang/php4/pkg-plist
index 9cce21b9950b..fb05a71b4961 100644
--- a/lang/php4/pkg-plist
+++ b/lang/php4/pkg-plist
@@ -193,6 +193,7 @@ include/php/regex/regex.h
include/php/regex/regex2.h
include/php/regex/regex_extra.h
include/php/regex/utils.h
+lib/php/%%EXT_DIR%%/.keepme
lib/php/build/Makefile.global
lib/php/build/acinclude.m4
lib/php/build/mkdep.awk
@@ -241,7 +242,6 @@ lib/php/build/shtool
@dirrm include/php/main
@dirrm include/php/regex
@dirrm include/php/
-@exec mkdir %D/lib/php/%%EXT_DIR%%
@unexec rmdir %D/lib/php/%%EXT_DIR%% 2> /dev/null || true
@dirrm lib/php/build
@unexec rmdir %D/lib/php 2> /dev/null || true