summaryrefslogtreecommitdiff
path: root/lang/php4/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-05-07 23:30:30 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-05-07 23:30:30 +0000
commitac9bdc26efbf36f809e83906eb42f5ecd914844e (patch)
tree9311e77e6d0e13a736e04ba570264854e9f57ef3 /lang/php4/Makefile
parentAdd gaphor 0.3.1, UML modeling environment written in Python. (diff)
- Add sysvmsg extension [1]
- Add XML_RPC to PEAR bootstrap [2] - Use the official pcre fix [3] - Bump PORTREVISION Requested by: Andy Smith <andy@strugglers.net> [1] Submitted by: thierry [2] Obtained from: php CVS [3]
Diffstat (limited to 'lang/php4/Makefile')
-rw-r--r--lang/php4/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 4a47600a5c5f..42990cf8458e 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -21,6 +21,7 @@
PORTNAME= php4
PORTVERSION= 4.3.6
+PORTREVISION= 1
CATEGORIES?= lang devel www
MASTER_SITES= http://www.php.net/distributions/:release \
http://it.php.net/distributions/:release \
@@ -136,8 +137,8 @@ ALL_OPTIONS= BCMATH BZIP2 CALENDAR CDB CRACK CTYPE CURL DB4 DBASE DBX DIO \
MCRYPT MHASH MIME MING MNOGOSEARCH MSSQL MYSQL NCURSES \
OPENLDAP OPENSSL ORACLE OVERLOAD PCNTL PCRE PDFLIB POSIX \
POSTGRESQL PSPELL READLINE RECODE SESSION SHMOP SNMP SOCKETS \
- SYBASEDB SYBASECT SYSVSEM SYSVSHM TOKENIZER UNIXODBC WDDX XML \
- XMLRPC XSLT YAZ YP ZIP ZLIB
+ SYBASEDB SYBASECT SYSVMSG SYSVSEM SYSVSHM TOKENIZER UNIXODBC \
+ WDDX XML XMLRPC XSLT YAZ YP ZIP ZLIB
.for opt in ${ALL_OPTIONS}
.if defined(WITH_${opt}) || defined(WITHOUT_${opt})
@@ -182,7 +183,6 @@ SCRIPTS_ENV+= SEL_OPTIONS="${SEL_OPTIONS}" \
.if !defined(WITHOUT_CLI) && !defined(WITHOUT_PEAR)
WITH_PCRE= yes
WITH_XML= yes
-WITH_XMLRPC= yes
.endif
.if defined(WITH_CDB) || defined(WITH_DB4) || defined(WITH_GDBM) || defined(WITH_INIFILE)
@@ -495,6 +495,10 @@ LIB_DEPENDS+= ct.2:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+=--with-sybase-ct=${LOCALBASE}
.endif
+.if defined(WITH_SYSVMSG)
+CONFIGURE_ARGS+=--enable-sysvmsg
+.endif
+
.if defined(WITH_SYSVSEM)
CONFIGURE_ARGS+=--enable-sysvsem
.endif