summaryrefslogtreecommitdiff
path: root/lang/perl5.8/files
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2003-10-27 19:48:03 +0000
committerAnton Berezin <tobez@FreeBSD.org>2003-10-27 19:48:03 +0000
commit1aee5817e8ee565d8efb60984a85c74ae48d025a (patch)
tree4a40734d22a51c5b390102e6b181374200a171c0 /lang/perl5.8/files
parentChange this ports a slave ports. (diff)
Update to 5.8.1.
Also: Make suidperl optional (ENABLE_SUIDPERL knob). Switch to perlmalloc by default, unless threaded perl is built, to improve performance. Modernize pkg-plist (switch to SITE_PERL where possible). Update WWW. Many thanks to foxfair who prepared most of this update.
Diffstat (limited to 'lang/perl5.8/files')
-rw-r--r--lang/perl5.8/files/patch-CGI.pm15
-rw-r--r--lang/perl5.8/files/patch-Install.pm13
-rw-r--r--lang/perl5.8/files/patch-Safe.pm83
-rw-r--r--lang/perl5.8/files/patch-ac38
-rw-r--r--lang/perl5.8/files/patch-ad20
-rw-r--r--lang/perl5.8/files/patch-ae12
-rw-r--r--lang/perl5.8/files/patch-af25
-rw-r--r--lang/perl5.8/files/patch-lastcloseparen31
-rw-r--r--lang/perl5.8/files/patch-lib_pm45
-rw-r--r--lang/perl5.8/files/patch-perl.c42
10 files changed, 22 insertions, 302 deletions
diff --git a/lang/perl5.8/files/patch-CGI.pm b/lang/perl5.8/files/patch-CGI.pm
deleted file mode 100644
index 1af91639808f..000000000000
--- a/lang/perl5.8/files/patch-CGI.pm
+++ /dev/null
@@ -1,15 +0,0 @@
---- lib/CGI.pm.orig Tue Sep 30 10:17:22 2003
-+++ lib/CGI.pm Tue Sep 30 10:20:20 2003
-@@ -1532,8 +1532,10 @@ sub startform {
- $method = lc($method) || 'post';
- $enctype = $enctype || &URL_ENCODED;
- unless (defined $action) {
-- $action = $self->url(-absolute=>1,-path=>1);
-- $action .= "?$ENV{QUERY_STRING}" if $ENV{QUERY_STRING};
-+ $action = $self->escapeHTML($self->url(-absolute=>1,-path=>1));
-+ if (length($ENV{QUERY_STRING})>0) {
-+ $action .= "?".$self->escapeHTML($ENV{QUERY_STRING},1);
-+ }
- }
- $action = qq(action="$action");
- my($other) = @other ? " @other" : '';
diff --git a/lang/perl5.8/files/patch-Install.pm b/lang/perl5.8/files/patch-Install.pm
deleted file mode 100644
index 228b24a1088a..000000000000
--- a/lang/perl5.8/files/patch-Install.pm
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- lib/ExtUtils/Install.pm.orig Fri Feb 23 03:57:55 2001
-+++ lib/ExtUtils/Install.pm Wed Jul 10 17:57:13 2002
-@@ -132,7 +132,7 @@
- $diff++;
- }
-
-- if ($diff){
-+ if ($diff||1){
- if (-f $targetfile){
- forceunlink($targetfile) unless $nonono;
- } else {
diff --git a/lang/perl5.8/files/patch-Safe.pm b/lang/perl5.8/files/patch-Safe.pm
deleted file mode 100644
index 12873700b9aa..000000000000
--- a/lang/perl5.8/files/patch-Safe.pm
+++ /dev/null
@@ -1,83 +0,0 @@
---- ext/Opcode/Safe.pm.orig Mon Apr 21 16:37:46 2003
-+++ ext/Opcode/Safe.pm Mon Apr 21 16:37:52 2003
-@@ -3,7 +3,7 @@ package Safe;
- use 5.003_11;
- use strict;
-
--our $VERSION = "2.07";
-+$Safe::VERSION = "2.09";
-
- use Carp;
-
-@@ -47,7 +47,7 @@ sub new {
- # the whole glob *_ rather than $_ and @_ separately, otherwise
- # @_ in non default packages within the compartment don't work.
- $obj->share_from('main', $default_share);
-- Opcode::_safe_pkg_prep($obj->{Root});
-+ Opcode::_safe_pkg_prep($obj->{Root}) if($Opcode::VERSION > 1.04);
- return $obj;
- }
-
-@@ -155,7 +155,7 @@ sub share_from {
- my $no_record = shift || 0;
- my $root = $obj->root();
- croak("vars not an array ref") unless ref $vars eq 'ARRAY';
-- no strict 'refs';
-+ no strict 'refs';
- # Check that 'from' package actually exists
- croak("Package \"$pkg\" does not exist")
- unless keys %{"$pkg\::"};
-@@ -190,7 +190,7 @@ sub share_record {
- sub share_redo {
- my $obj = shift;
- my $shares = \%{$obj->{Shares} ||= {}};
-- my($var, $pkg);
-+ my($var, $pkg);
- while(($var, $pkg) = each %$shares) {
- # warn "share_redo $pkg\:: $var";
- $obj->share_from($pkg, [ $var ], 1);
-@@ -214,11 +214,11 @@ sub reval {
- # Create anon sub ref in root of compartment.
- # Uses a closure (on $expr) to pass in the code to be executed.
- # (eval on one line to keep line numbers as expected by caller)
-- my $evalcode = sprintf('package %s; sub { eval $expr; }', $root);
-+ my $evalcode = sprintf('package %s; sub { @_ = (); eval $expr; }', $root);
- my $evalsub;
-
-- if ($strict) { use strict; $evalsub = eval $evalcode; }
-- else { no strict; $evalsub = eval $evalcode; }
-+ if ($strict) { use strict; $evalsub = eval $evalcode; }
-+ else { no strict; $evalsub = eval $evalcode; }
-
- return Opcode::_safe_call_sv($root, $obj->{Mask}, $evalsub);
- }
-@@ -228,7 +228,7 @@ sub rdo {
- my $root = $obj->{Root};
-
- my $evalsub = eval
-- sprintf('package %s; sub { do $file }', $root);
-+ sprintf('package %s; sub { @_ = (); do $file }', $root);
- return Opcode::_safe_call_sv($root, $obj->{Mask}, $evalsub);
- }
-
-@@ -383,8 +383,9 @@ This shares the variable(s) in the argum
- This is almost identical to exporting variables using the L<Exporter>
- module.
-
--Each NAME must be the B<name> of a variable, typically with the leading
--type identifier included. A bareword is treated as a function name.
-+Each NAME must be the B<name> of a non-lexical variable, typically
-+with the leading type identifier included. A bareword is treated as a
-+function name.
-
- Examples of legal names are '$foo' for a scalar, '@foo' for an
- array, '%foo' for a hash, '&foo' or 'foo' for a subroutine and '*foo'
-@@ -426,7 +427,7 @@ C<main::> package to the code inside the
- Any attempt by the code in STRING to use an operator which is not permitted
- by the compartment will cause an error (at run-time of the main program
- but at compile-time for the code in STRING). The error is of the form
--"%s trapped by operation mask operation...".
-+"'%s' trapped by operation mask...".
-
- If an operation is trapped in this way, then the code in STRING will
- not be executed. If such a trapped operation occurs or any other
diff --git a/lang/perl5.8/files/patch-ac b/lang/perl5.8/files/patch-ac
deleted file mode 100644
index f7255c5d354c..000000000000
--- a/lang/perl5.8/files/patch-ac
+++ /dev/null
@@ -1,38 +0,0 @@
-
-$FreeBSD$
-
---- hints/freebsd.sh.orig Sat Jun 1 20:03:12 2002
-+++ hints/freebsd.sh Tue Apr 1 14:17:18 2003
-@@ -98,6 +98,13 @@
- ;;
- esac
- libswanted=`echo $libswanted | sed 's/ malloc / /'`
-+ libswanted=`echo $libswanted | sed 's/ bind / /'`
-+ libswanted=`echo $libswanted | sed 's/ iconv / /'`
-+ d_setregid='define'
-+ d_setreuid='define'
-+ d_setegid='define'
-+ d_seteuid='define'
-+ d_dosuid='define'
- ;;
- esac
-
-@@ -124,7 +131,7 @@
- fi
- lddlflags='-Bshareable'
- fi
-- cccdlflags='-DPIC -fpic'
-+ cccdlflags='-DPIC -fPIC'
- ;;
- esac
-
-@@ -223,6 +230,9 @@
- 4.*) # 4.x has gethostbyaddr_r but it is
- # "Temporary function, not threadsafe"...
- d_gethostbyaddr_r="undef"
-+ d_gethostbyaddr_r_proto="undef"
-+ ;;
-+ 5.*) d_gethostbyaddr_r="undef"
- d_gethostbyaddr_r_proto="undef"
- ;;
- esac
diff --git a/lang/perl5.8/files/patch-ad b/lang/perl5.8/files/patch-ad
deleted file mode 100644
index fa9bf3ebfc2e..000000000000
--- a/lang/perl5.8/files/patch-ad
+++ /dev/null
@@ -1,20 +0,0 @@
-$FreeBSD$
-
---- perl.h.ORIG Thu Mar 22 07:05:02 2001
-+++ perl.h Tue Apr 10 20:29:46 2001
-@@ -151,6 +151,15 @@
-
- */
-
-+/* needed for IAMSUID case for 4.4BSD systems
-+ * XXX there should probably be a Configure variable
-+ */
-+
-+#ifdef I_SYS_PARAM
-+#if (defined (BSD) && (BSD >= 199306))
-+# include <sys/mount.h>
-+#endif /* !BSD */
-+#endif /* !I_SYS_PARAM */
-
- class CPerlObj;
-
diff --git a/lang/perl5.8/files/patch-ae b/lang/perl5.8/files/patch-ae
deleted file mode 100644
index 27c3d9b7bd94..000000000000
--- a/lang/perl5.8/files/patch-ae
+++ /dev/null
@@ -1,12 +0,0 @@
-$FreeBSD$
-
---- makedepend.SH.ORIG Fri Jul 24 06:00:58 1998
-+++ makedepend.SH Thu Jul 30 17:08:37 1998
-@@ -68,6 +68,7 @@
- case "$osname" in
- os2) ;;
- netbsd) ;;
-+ freebsd) ;;
- *) $touch $firstmakefile ;;
- esac
- fi
diff --git a/lang/perl5.8/files/patch-af b/lang/perl5.8/files/patch-af
deleted file mode 100644
index 24232388a5f8..000000000000
--- a/lang/perl5.8/files/patch-af
+++ /dev/null
@@ -1,25 +0,0 @@
-$FreeBSD$
-
---- Configure.orig Fri Jul 19 00:55:15 2002
-+++ Configure Tue Dec 10 12:12:35 2002
-@@ -308,7 +308,7 @@ cppflags=''
- ldflags=''
- lkflags=''
- locincpth=''
--optimize=''
-+optimize=${CFLAGS:-''}
- cf_email=''
- cf_by=''
- cf_time=''
-@@ -9933,8 +9933,9 @@ eval $setvar
-
- : see if crypt exists
- echo " "
--set crypt d_crypt
--eval $inlibc
-+: no, crypt is NOT in libc on FreeBSD
-+: set crypt d_crypt
-+: eval $inlibc
- case "$d_crypt" in
- $define) cryptlib='' ;;
- *) if set crypt val -f d_crypt; eval $csym; $val; then
diff --git a/lang/perl5.8/files/patch-lastcloseparen b/lang/perl5.8/files/patch-lastcloseparen
deleted file mode 100644
index 3676fed904de..000000000000
--- a/lang/perl5.8/files/patch-lastcloseparen
+++ /dev/null
@@ -1,31 +0,0 @@
---- pp_hot.c.orig Mon Jul 14 10:20:29 2003
-+++ pp_hot.c Mon Jul 14 10:21:31 2003
-@@ -1406,7 +1406,7 @@ yup: /* Confirmed by INTUIT */
- rx->startp[0] = s - truebase;
- rx->endp[0] = s - truebase + rx->minlen;
- }
-- rx->nparens = rx->lastparen = 0; /* used by @- and @+ */
-+ rx->nparens = rx->lastparen = rx->lastcloseparen = 0; /* used by @-, @+, and $^N */
- LEAVE_SCOPE(oldsave);
- RETPUSHYES;
-
---- sv.c.orig Mon Jul 14 10:21:49 2003
-+++ sv.c Mon Jul 14 10:22:35 2003
-@@ -11474,6 +11474,7 @@ perl_clone_using(PerlInterpreter *proto_
- PL_regstartp = (I32*)NULL;
- PL_regendp = (I32*)NULL;
- PL_reglastparen = (U32*)NULL;
-+ PL_reglastcloseparen = (U32*)NULL;
- PL_regtill = Nullch;
- PL_reg_start_tmp = (char**)NULL;
- PL_reg_start_tmpl = 0;
---- regexec.c.orig Mon Jul 14 10:37:02 2003
-+++ regexec.c Mon Jul 14 10:37:34 2003
-@@ -2107,6 +2107,7 @@ S_regtry(pTHX_ regexp *prog, char *start
- PL_reglastparen = &prog->lastparen;
- PL_reglastcloseparen = &prog->lastcloseparen;
- prog->lastparen = 0;
-+ prog->lastcloseparen = 0;
- PL_regsize = 0;
- DEBUG_r(PL_reg_starttry = startpos);
- if (PL_reg_start_tmpl <= prog->nparens) {
diff --git a/lang/perl5.8/files/patch-lib_pm b/lang/perl5.8/files/patch-lib_pm
deleted file mode 100644
index b3299535adfd..000000000000
--- a/lang/perl5.8/files/patch-lib_pm
+++ /dev/null
@@ -1,45 +0,0 @@
-$FreeBSD$
-
---- lib/lib_pm.PL.orig Wed Jun 5 03:05:46 2002
-+++ lib/lib_pm.PL Tue Aug 20 21:32:55 2002
-@@ -71,30 +71,31 @@ sub import {
-
- my %names;
- foreach (reverse @_) {
-- if ($_ eq '') {
-+ my $path = $_;
-+ if ($path eq '') {
- require Carp;
- Carp::carp("Empty compile time value given to use lib");
- }
-
-- local $_ = _nativize($_);
-+ $path = _nativize($path);
-
-- if (-e && ! -d _) {
-+ if (-e $path && ! -d _) {
- require Carp;
- Carp::carp("Parameter to use lib must be directory, not file");
- }
-- unshift(@INC, $_);
-+ unshift(@INC, $path);
- # Add any previous version directories we found at configure time
- foreach my $incver (@inc_version_list)
- {
- my $dir = $Is_MacOS
-- ? File::Spec->catdir( $_, $incver )
-- : "$_/$incver";
-+ ? File::Spec->catdir( $path, $incver )
-+ : "$path/$incver";
- unshift(@INC, $dir) if -d $dir;
- }
-- # Put a corresponding archlib directory in front of $_ if it
-- # looks like $_ has an archlib directory below it.
-+ # Put a corresponding archlib directory in front of $path if it
-+ # looks like $path has an archlib directory below it.
- my($arch_auto_dir, $arch_dir, $version_dir, $version_arch_dir)
-- = _get_dirs($_);
-+ = _get_dirs($path);
- unshift(@INC, $arch_dir) if -d $arch_auto_dir;
- unshift(@INC, $version_dir) if -d $version_dir;
- unshift(@INC, $version_arch_dir) if -d $version_arch_dir;
diff --git a/lang/perl5.8/files/patch-perl.c b/lang/perl5.8/files/patch-perl.c
index b9b348bef069..69c0e55bb12e 100644
--- a/lang/perl5.8/files/patch-perl.c
+++ b/lang/perl5.8/files/patch-perl.c
@@ -1,58 +1,60 @@
$FreeBSD$
---- perl.c.orig Sun Jun 2 12:29:01 2002
-+++ perl.c Sun Jun 2 12:30:14 2002
-@@ -3407,6 +3407,26 @@
- #endif /* VMS */
- }
-
+--- perl.c.orig Mon Oct 27 20:32:18 2003
++++ perl.c Mon Oct 27 20:33:57 2003
+@@ -3945,6 +3945,27 @@ S_init_perllib(pTHX)
+ /* Use the ~-expanded versions of APPLLIB (undocumented),
+ ARCHLIB PRIVLIB SITEARCH SITELIB VENDORARCH and VENDORLIB
+ */
+#ifdef SITEARCH_EXP
+ /* sitearch is always relative to sitelib on Windows for
+ * DLL-based path intuition to work correctly */
+# if !defined(WIN32)
-+ incpush(SITEARCH_EXP, FALSE, FALSE);
++ incpush(SITEARCH_EXP, FALSE, FALSE, TRUE);
+# endif
+#endif
+
+#ifdef SITELIB_EXP
+# if defined(WIN32)
-+ incpush(SITELIB_EXP, TRUE, FALSE); /* this picks up sitearch as well */
++ /* this picks up sitearch as well */
++ incpush(SITELIB_EXP, TRUE, FALSE, TRUE);
+# else
-+ incpush(SITELIB_EXP, FALSE, FALSE);
++ incpush(SITELIB_EXP, FALSE, FALSE, TRUE);
+# endif
+#endif
+
+#ifdef SITELIB_STEM /* Search for version-specific dirs below here */
-+ incpush(SITELIB_STEM, FALSE, TRUE);
++ incpush(SITELIB_STEM, FALSE, TRUE, TRUE);
+#endif
+
- /* Use the ~-expanded versions of APPLLIB (undocumented),
- ARCHLIB PRIVLIB SITEARCH SITELIB VENDORARCH and VENDORLIB
- */
-@@ -3445,26 +3465,6 @@
- incpush(PRIVLIB_EXP, TRUE, FALSE);
+ #ifdef APPLLIB_EXP
+ incpush(APPLLIB_EXP, TRUE, TRUE, TRUE);
+ #endif
+@@ -3980,27 +4001,6 @@ S_init_perllib(pTHX)
+ incpush(PRIVLIB_EXP, TRUE, FALSE, TRUE);
#else
- incpush(PRIVLIB_EXP, FALSE, FALSE);
+ incpush(PRIVLIB_EXP, FALSE, FALSE, TRUE);
-#endif
-
-#ifdef SITEARCH_EXP
- /* sitearch is always relative to sitelib on Windows for
- * DLL-based path intuition to work correctly */
-# if !defined(WIN32)
-- incpush(SITEARCH_EXP, FALSE, FALSE);
+- incpush(SITEARCH_EXP, FALSE, FALSE, TRUE);
-# endif
-#endif
-
-#ifdef SITELIB_EXP
-# if defined(WIN32)
-- incpush(SITELIB_EXP, TRUE, FALSE); /* this picks up sitearch as well */
+- /* this picks up sitearch as well */
+- incpush(SITELIB_EXP, TRUE, FALSE, TRUE);
-# else
-- incpush(SITELIB_EXP, FALSE, FALSE);
+- incpush(SITELIB_EXP, FALSE, FALSE, TRUE);
-# endif
-#endif
-
-#ifdef SITELIB_STEM /* Search for version-specific dirs below here */
-- incpush(SITELIB_STEM, FALSE, TRUE);
+- incpush(SITELIB_STEM, FALSE, TRUE, TRUE);
#endif
#ifdef PERL_VENDORARCH_EXP