summaryrefslogtreecommitdiff
path: root/lang/perl5.8/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-03-01 08:54:11 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-03-01 08:54:11 +0000
commit8ae891fb979948521c15954305eb110cd5719b8c (patch)
treeffd4f4e2c02588968b97f797685ffcfd150432fc /lang/perl5.8/Makefile
parent- Chase libraries and fix the build with new silc-toolkit (diff)
Fix "pkg_add -r perl" for 5.2-CURRENT (and later). This will now install
perl 5.8 for 5.2-CURRENT. Approved by: perl
Diffstat (limited to '')
-rw-r--r--lang/perl5.8/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/perl5.8/Makefile b/lang/perl5.8/Makefile
index 9a36b92d8cea..8f1fcaa30664 100644
--- a/lang/perl5.8/Makefile
+++ b/lang/perl5.8/Makefile
@@ -24,6 +24,10 @@ PERL_VER= 5.8.2
PERL_ARCH= mach
PERL_VERSION= ${PERL_VER}
+.if ${OSVERSION} < 502100
+LATEST_LINK= perl5.8
+.endif
+
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT=Configure
CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} \
@@ -206,8 +210,6 @@ MAN3+= GDBM_File.3
.endif
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}
-LATEST_LINK= perl5.8
-
test:
@(cd ${WRKSRC}; make test)