summaryrefslogtreecommitdiff
path: root/lang/otcl/Makefile
diff options
context:
space:
mode:
authorR. Imura <imura@FreeBSD.org>2000-02-23 14:02:37 +0000
committerR. Imura <imura@FreeBSD.org>2000-02-23 14:02:37 +0000
commitdc20f854ce51a8039551af221bd9bc599bc60882 (patch)
tree5ce018ca7cba40bf4378beb0ef558b387242a037 /lang/otcl/Makefile
parentUpdate to version 2.2.1b. (diff)
Update to version 1.0a5.
PR: 16917 Submitted by: maintainer
Diffstat (limited to 'lang/otcl/Makefile')
-rw-r--r--lang/otcl/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/lang/otcl/Makefile b/lang/otcl/Makefile
index 8d1cbf7fd5a1..eb2f4959fb30 100644
--- a/lang/otcl/Makefile
+++ b/lang/otcl/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: otcl
-# Version required: 1.0a4
+# Version required: 1.0a5
# Date created: 23 April 1999
# Whom: obonilla
#
# $FreeBSD$
#
-DISTNAME= otcl-1.0a4
+DISTNAME= otcl-1.0a5
CATEGORIES= lang
MASTER_SITES= http://www-mash.cs.berkeley.edu/dist/
@@ -15,11 +15,13 @@ MAINTAINER= obonilla@fisicc-ufm.edu
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --includedir=${PREFIX}/include/tcl8.2/generic \
- --with-tcl-ver=8.2
+CONFIGURE_ARGS= --with-tcl-ver=8.2 --with-tk-ver=8.2
+USE_AUTOCONF= yes
post-install:
- ${LN} -sf libotcl.so.1 ${PREFIX}/lib/libotcl.so
+ ${LN} -sf libotcl.so ${PREFIX}/lib/libotcl.so.1
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+ strip ${PREFIX}/bin/otclsh
+ strip ${PREFIX}/bin/owish
.include <bsd.port.mk>