summaryrefslogtreecommitdiff
path: root/lang/onyx/Makefile
diff options
context:
space:
mode:
authorJason Evans <jasone@FreeBSD.org>2002-02-11 01:34:57 +0000
committerJason Evans <jasone@FreeBSD.org>2002-02-11 01:34:57 +0000
commitf509da85c2b8840bb73805111b74dea4e456d562 (patch)
treed033ab6bdd79abeab22e520220a43bf2c9b451f4 /lang/onyx/Makefile
parentAdd libedit 2.6.4. (diff)
Update to onyx 3.0.0.
Diffstat (limited to 'lang/onyx/Makefile')
-rw-r--r--lang/onyx/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/lang/onyx/Makefile b/lang/onyx/Makefile
index 3bdf3b4131b0..d605b4805522 100644
--- a/lang/onyx/Makefile
+++ b/lang/onyx/Makefile
@@ -6,22 +6,26 @@
#
PORTNAME= onyx
-PORTVERSION= 2.3.1
+PORTVERSION= 3.0.0
CATEGORIES= lang
MASTER_SITES= http://www.canonware.com/download/onyx/
MAINTAINER= jasone@FreeBSD.org
BUILD_DEPENDS= cook:${PORTSDIR}/devel/cook
+LIB_DEPENDS= edit.5:${PORTSDIR}/devel/libedit
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libedit-prefix=${PREFIX}
INSTALLS_SHLIB= yes
MAN1= onyx.1
MANCOMPRESSED= no
+PLIST_SUB= ONYX_VERSION=${PORTVERSION}
+
do-build:
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook libs mods bins)
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook)
do-install:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook install)