summaryrefslogtreecommitdiff
path: root/lang/onyx/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 13:02:46 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 13:02:46 +0000
commit74b0ae42fd2b8e895a6e0cd679a56b94673c0155 (patch)
treed7b8c8ca0851971a79995e9e0b1cd51b329eda64 /lang/onyx/Makefile
parentugprade to 0.6.0 (diff)
upgrade to 4.1.0
PR: 45445 Submitted by: Ports Fury
Diffstat (limited to 'lang/onyx/Makefile')
-rw-r--r--lang/onyx/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/lang/onyx/Makefile b/lang/onyx/Makefile
index 088e902a8376..1b87a7b3fce6 100644
--- a/lang/onyx/Makefile
+++ b/lang/onyx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= onyx
-PORTVERSION= 3.0.2
+PORTVERSION= 4.1.0
CATEGORIES= lang
MASTER_SITES= http://www.canonware.com/download/onyx/
@@ -16,11 +16,11 @@ BUILD_DEPENDS= cook:${PORTSDIR}/devel/cook
LIB_DEPENDS= edit.5:${PORTSDIR}/devel/libedit
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libedit-prefix=${PREFIX}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-libedit-prefix=${LOCALBASE}
INSTALLS_SHLIB= yes
-MAN1= onyx.1
-MANCOMPRESSED= no
+MAN1= onyx.1 onyx_config.1
PLIST_SUB= ONYX_VERSION=${PORTVERSION}
@@ -31,7 +31,7 @@ do-install:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook install)
post-install:
- @strip ${PREFIX}/bin/onyx
- @cat ${PKGMESSAGE}
+ @${STRIP_CMD} ${PREFIX}/bin/onyx
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>