summaryrefslogtreecommitdiff
path: root/lang/nhc98/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2003-10-11 09:25:56 +0000
committerOliver Braun <obraun@FreeBSD.org>2003-10-11 09:25:56 +0000
commit16c9ed6c90b4d667d7a76497305607f8592ab007 (patch)
tree897da6e676b65d2003e55954b9423449edbecb37 /lang/nhc98/Makefile
parentAdd CONFLICTS for ports that install files with the same name. (diff)
* Add upstream patch file.
* Add ONLY_FOR_ARCHS=i386. * Utilize DOCSDIR. * Use CONFLICTS instead of checking conflict with hs-hmake in the ports Makefile.
Diffstat (limited to 'lang/nhc98/Makefile')
-rw-r--r--lang/nhc98/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/lang/nhc98/Makefile b/lang/nhc98/Makefile
index a5dd038b2646..977984ec1714 100644
--- a/lang/nhc98/Makefile
+++ b/lang/nhc98/Makefile
@@ -13,11 +13,14 @@ DISTNAME= ${PORTNAME}src-${PORTVERSION}
DIST_SUBDIR= nhc98
PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= patch-1.16-typesyn
+PATCHFILES= patch-1.16-typesyn \
+ patch-1.16-ghc6
MAINTAINER= obraun@FreeBSD.org
COMMENT= A fully-fledged compiler for Haskell 98
+ONLY_FOR_ARCHS= i386
+
USE_REINPLACE= yes
.include <bsd.port.pre.mk>
@@ -36,11 +39,13 @@ CONFIGURE_ARGS+= --buildwith=ghc
.endif
.if !defined(NOPORTDOCS)
-CONFIGURE_ARGS+= --docdir=${PREFIX}/share/doc/nhc98 +docs
+CONFIGURE_ARGS+= --docdir=${DOCSDIR} +docs
.endif
MAN1= harch.1 hmake.1 hp2graph.1 nhc98.1
+CONFLICTS= hs-hmake-*
+
post-patch:
@${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
.for file in Decl FillIn Process
@@ -52,16 +57,6 @@ post-configure:
@${ECHO} "LIBDIR=${PREFIX}/lib/nhc98" \
>> ${WRKSRC}/targets/ix86-FreeBSD/config.cache
-pre-install:
-.if exists(${PREFIX}/bin/hmake) && !defined(OVERRIDE_HMAKE)
- @${ECHO} ""
- @${ECHO} "It seems that there is already a version of hmake installed on"
- @${ECHO} "this system. Since hmake is part of nhc98, please deinstall it,"
- @${ECHO} "or define OVERRIDE_HMAKE to override the installed version."
- @${ECHO} ""
- @${FALSE}
-.endif
-
post-install:
${SED} -e "s#/usr/doc/nhc98#${PREFIX}/share/doc/nhc98#" \
< ${WRKSRC}/man/nhc98.1 > ${WRKSRC}/man/nhc98.1.fix
@@ -69,7 +64,7 @@ post-install:
${RM} ${WRKSRC}/man/nhc98.1.fix
.if !defined(NOPORTDOCS)
.for directory in . bugs examples hmake implementation-notes libs
- ${RM} -r ${PREFIX}/share/doc/nhc98/${directory}/CVS
+ ${RM} -r ${DOCSDIR}/${directory}/CVS
.endfor
.endif