summaryrefslogtreecommitdiff
path: root/lang/moscow_ml/files/patch-dynlibs::intinf::Makefile
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2002-05-30 10:47:57 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2002-05-30 10:47:57 +0000
commitdcd902f84652155189b05b0e4abe32bc2a8237ad (patch)
tree2e8b4a5c8f29b87e6704f9102917bddf02be03ba /lang/moscow_ml/files/patch-dynlibs::intinf::Makefile
parentUnbreak port if INCOWN and INCGRP are not defined. (diff)
Upgrade to v2.0.
Submitted by: Johannes 5 Joemann <joemann@beefree.free.de>
Diffstat (limited to 'lang/moscow_ml/files/patch-dynlibs::intinf::Makefile')
-rw-r--r--lang/moscow_ml/files/patch-dynlibs::intinf::Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/lang/moscow_ml/files/patch-dynlibs::intinf::Makefile b/lang/moscow_ml/files/patch-dynlibs::intinf::Makefile
new file mode 100644
index 000000000000..2302c529bd14
--- /dev/null
+++ b/lang/moscow_ml/files/patch-dynlibs::intinf::Makefile
@@ -0,0 +1,32 @@
+--- dynlibs/intinf/Makefile.orig Wed Feb 16 16:36:57 2000
++++ dynlibs/intinf/Makefile Fri Apr 12 02:21:26 2002
+@@ -10,10 +10,11 @@
+ include ../../Makefile.inc
+
+ OPTS=-fno-defer-pop
+-CFLAGS=-Dunix -O2 $(OPTS) $(ADDDYNLIBCFLAGS) -I$(INCDIR) -I ${GMPDIR}
++CFLAGS=-Dunix -O2 $(OPTS) $(ADDDYNLIBCFLAGS) -I$(INCDIR)
+
+ MOSMLTOOLS=camlrunm $(MOSMLHOME)/tools
+-MOSMLC=mosmlc -c
++#MOSMLC=mosmlc -c
++MOSMLC=../../runtime/camlrunm ../../compiler/mosmlcmp -stdlib ../../mosmllib -P none
+ MOSMLL=mosmlc
+ MOSMLLEX=mosmllex
+ MOSMLYACC=mosmlyac
+@@ -21,13 +22,13 @@
+ all: libmgmp.so IntInf.uo
+
+ install:
+- cp libmgmp.so $(LIBDIR)
++ cp libmgmp.so IntInf.sig IntInf.ui IntInf.uo $(LIBDIR)
+
+ intinf.o: intinf.c
+ $(CC) $(CFLAGS) -c -o intinf.o intinf.c
+
+ libmgmp.so: intinf.o
+- $(DYNLD) -o libmgmp.so intinf.o ${GMPDIR}/libgmp.a
++ $(DYNLD) -o libmgmp.so intinf.o -lgmp
+
+ test:
+ mosml testintinf.sml