summaryrefslogtreecommitdiff
path: root/lang/itcl/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-07-28 14:53:46 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-07-28 14:53:46 +0000
commit3295fa4f6e3f5d505ba1cae15385579d1a0bf31e (patch)
tree52b438d6e53f18c71a5dc4c07feb9f29ec0a5de7 /lang/itcl/Makefile
parentCorrect typo. (diff)
Update to itcl 3.2. Don't build stubs. Run tests after tests.
Install iwidgets2.2.0 in addition to 3.0.0. The older version is still in use by some scripts and continues to come with itcl3.2. Change maintainer to ports@ Approved by: maintainer's silence
Diffstat (limited to 'lang/itcl/Makefile')
-rw-r--r--lang/itcl/Makefile63
1 files changed, 36 insertions, 27 deletions
diff --git a/lang/itcl/Makefile b/lang/itcl/Makefile
index 3789f8d1db85..1c67b768a5e3 100644
--- a/lang/itcl/Makefile
+++ b/lang/itcl/Makefile
@@ -6,51 +6,60 @@
#
PORTNAME= itcl
-PORTVERSION= 3.0.1
+PORTVERSION= ${MAJOR}.${MINOR}
CATEGORIES= lang
-MASTER_SITES= ftp://ftp.tcltk.com/pub/itcl/
-DISTNAME= itcl3.0.1
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=incrtcl
+DISTNAME= itcl${PORTVERSION}
-MAINTAINER= dmlb@ragnet.demon.co.uk
+MAINTAINER= ports@freebsd.org
-LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
+LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83
-WRKSRC= ${WRKDIR}/itcl3.0.1/itcl/unix
+WRKSRC= ${WRKDIR}/${DISTNAME}/itcl
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared --with-tcl=${PREFIX}/lib/tcl8.2
-CONFIGURE_ENV= PORTSDIR=${PORTSDIR} ITCL_LIB_FILE=${ITCL_LIB_FILE}
-PKGINSTALL= ${PORTSDIR}/lang/tcl82/pkg-install.tclsh
-PKGDEINSTALL= ${PORTSDIR}/lang/tcl82/pkg-deinstall.tclsh
+PKGINSTALL= ${PORTSDIR}/lang/tcl83/pkg-install.tclsh
+PKGDEINSTALL= ${PORTSDIR}/lang/tcl83/pkg-deinstall.tclsh
+MAKE_ENV+= ${PLIST_SUB} \
+ SHLIB_MAJOR=${SHLIB_MAJOR} SHLIB_MINOR=${SHLIB_MINOR}
+
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - ./itcl${MAJOR}.${MINOR}/itcl
+
+.if defined(MAKE_JOBS)
+MAKE_ARGS+= -j$(MAKE_JOBS)
+.endif
SHLIB_MAJOR= 1
SHLIB_MINOR= 1
-MAKEFILE= makefile
-ITCL_LIB= libitcl30.so
+MAJOR= 3
+MINOR= 2
+PLIST_SUB+= MAJOR=${MAJOR} MINOR=${MINOR}
+ITCL_LIB= libitcl${MAJOR}${MINOR}.so
+MAKEFILE= ${FILESDIR}/Makefile.lib
-MANCOMPRESSED= yes
-MAN1= itclsh.1
+MANCOMPRESSED= no
MANN= body.n class.n code.n configbody.n delete.n ensemble.n find.n
MANN+= itcl.n itcl_class.n itcl_info.n itclvars.n local.n scope.n
-.include <bsd.port.pre.mk>
-
ITCL_LIB_FILE= ${ITCL_LIB}.${SHLIB_MAJOR}
-post-configure:
- @${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}
- @${CP} ${FILESDIR}/makefile ${WRKSRC}
+post-extract:
+ ${RM} ${WRKSRC}/pkgIndex.tcl
+
+post-patch:
+ ${PERL} -pi \
+ -e 's,package require Itcl,load [glob \
+ ${WRKSRC}/${ITCL_LIB}.${SHLIB_MAJOR}*],;' \
+ ${WRKSRC}/tests/*.test
-pre-build:
- @cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} \
- SHLIB_MAJOR=${SHLIB_MAJOR} SHLIB_MINOR=${SHLIB_MINOR} \
- TCL_PREFIX=${PREFIX}
+post-build test:
+ cd ${WRKSRC} && ${SETENV} ITCL_LIBRARY=${WRKSRC}/library \
+ ${PREFIX}/bin/tclsh8.3 tests/all.tcl
post-install:
- ${LN} -sf ${PREFIX}/bin/itclsh3.0 ${PREFIX}/bin/itclsh
- ${LN} -sf ${ITCL_LIB_FILE} ${PREFIX}/lib/${ITCL_LIB}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.n ${PREFIX}/man/mann/
.if exists(${PKGINSTALL})
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>