summaryrefslogtreecommitdiff
path: root/lang/ghc/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2004-01-15 22:56:11 +0000
committerOliver Braun <obraun@FreeBSD.org>2004-01-15 22:56:11 +0000
commitceb5689bb9fa3d0962aea642810b8dc4fc5c736a (patch)
treef4e2f4e331b15688cebce04890901a4fed519cda /lang/ghc/Makefile
parentAdd wolf3d, an unofficial Linux port of 1992 id Software game Wolfenstein 3D. (diff)
* Upgrade lang/ghc to 6.2.
* Welcome lang/ghc5 after repocopy from lang/ghc. * Say goodbye to lang/ghc6. * Fix dependency of devel/hs-tclhaskell-ghc and devel/hs-uni. Approved by: portmgr (marcus), maintainer Repocopy by: joe
Diffstat (limited to 'lang/ghc/Makefile')
-rw-r--r--lang/ghc/Makefile23
1 files changed, 8 insertions, 15 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index caa3e2ede243..84618179e2b1 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= ghc
-PORTVERSION= 5.04.3
-PORTREVISION= 1
+PORTVERSION= 6.2
CATEGORIES= lang haskell
MASTER_SITES= http://www.haskell.org/ghc/dist/${PORTVERSION}/:source \
http://www.haskell.org/ghc/dist/${PORTVERSION}/FreeBSD/:boot
@@ -61,6 +60,10 @@ CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
TMPDIR = ${WRKSRC}/tmp
MAKE_ENV += TMPDIR=${TMPDIR}
+# Just do a stage1 build
+ALL_TARGET = stage1
+MAKE_ENV += stage=1
+
pre-everything::
.if !defined(WITHOUT_PROFILE)
@${ECHO_CMD} "To build GHC without profiling libraries,"
@@ -70,21 +73,14 @@ pre-everything::
@${ECHO_CMD} "Building GHC without profiling libraries."
.endif
-post-extract:
.if defined(WITHOUT_PROFILE)
+post-extract:
@${ECHO} >>${WRKSRC}/mk/build.mk GhcLibWays=
.endif
- @${ECHO} >>${WRKSRC}/mk/build.mk SplitObjs=NO
post-patch:
- @${PERL} -pi -e 's/DrIFT/DrIFT-ghc/g; \
- s/DtdToHaskell/DtdToHaskell-ghc/g; \
- s/Xtract/Xtract-ghc/g' \
- ${WRKSRC}/ghc/mk/config.mk \
- ${WRKSRC}/hslibs/tools/DrIFT/Makefile \
- ${WRKSRC}/hslibs/tools/DtdToHaskell/Makefile \
- ${WRKSRC}/hslibs/tools/Xtract/Makefile
- @${REINPLACE_CMD} s+%%LOCALBASE%%+${LOCALBASE}+ ${WRKSRC}/ghc/rts/rts.conf.in
+ @${REINPLACE_CMD} s+%%LOCALBASE%%+${LOCALBASE}+ \
+ ${WRKSRC}/ghc/rts/package.conf.in
pre-configure:
@(cd ${BOOT_DIR} && ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS})
@@ -93,7 +89,4 @@ pre-configure:
pre-build:
@${MKDIR} ${TMPDIR}
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.post.mk>