summaryrefslogtreecommitdiff
path: root/lang/gcl/Makefile
diff options
context:
space:
mode:
authorJeffrey Hsu <hsu@FreeBSD.org>1995-02-12 21:10:03 +0000
committerJeffrey Hsu <hsu@FreeBSD.org>1995-02-12 21:10:03 +0000
commitb7306c24430b477596990f62973853199f69a3e7 (patch)
tree58a3bb3772bb1f2e50bb3b753bec12cbcfda8901 /lang/gcl/Makefile
parentSet MAKE_FLAGS so that `make PREFIX=...' works as expected. (diff)
gcl - GNU Common Lisp
Diffstat (limited to 'lang/gcl/Makefile')
-rw-r--r--lang/gcl/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/lang/gcl/Makefile b/lang/gcl/Makefile
new file mode 100644
index 000000000000..e43dedb1b842
--- /dev/null
+++ b/lang/gcl/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: gcl
+# Version required: 1.1
+# Date created: Wed Feb 8 01:49:11 1995
+# Whom: hsu
+#
+# $Id$
+#
+
+DISTNAME= gcl-1.1
+MASTER_SITES= ftp://ftp.cli.com/pub/gcl/ ftp://math.utexas.edu/pub/gcl/
+EXTRACT_SUFX= .tgz
+MAKEFILE= makefile
+
+INSTALL_COOKIE= ${WRKDIR}/.install_done
+install: build ${INSTALL_COOKIE}
+
+${INSTALL_COOKIE}:
+ @echo "===> Installing for ${DISTNAME}"
+ @${MAKE} ${.MAKEFLAGS} pre-install
+ @(cd ${WRKSRC}; ${MAKE} PREFIX_DIR=${PREFIX} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+ @${TOUCH} ${TOUCH_FLAGS} ${INSTALL_COOKIE}
+
+.include <bsd.port.mk>