summaryrefslogtreecommitdiff
path: root/lang/gcc30/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-11-14 19:32:21 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-11-14 19:32:21 +0000
commitb100e8414d81680287e84b45705517e6bd87bc5f (patch)
tree9c1d74a8f89fbf22372b603438c683b247fe8d94 /lang/gcc30/Makefile
parentIf built on a machine with GCC 3.2 or later; assume the machine has CPUTYPE (diff)
Fix the 1st problem hit trying to build this on FBSD 5.x.
Diffstat (limited to '')
-rw-r--r--lang/gcc30/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/gcc30/Makefile b/lang/gcc30/Makefile
index 1e8f4cb930a2..e0067cbecd17 100644
--- a/lang/gcc30/Makefile
+++ b/lang/gcc30/Makefile
@@ -34,6 +34,7 @@ CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
+USE_REINPLACE= yes
.endif
.if ${PORTOBJFORMAT} == "elf"
@@ -77,6 +78,10 @@ pre-configure:
@${TOUCH} ${SRCDIR}/gcc/cstamp-h.in
@${MKDIR} ${CONFIGURE_WRKSRC}
@${RM} -f ${SRCDIR}/gcc/*/*.info*
+.if ${OSVERSION} >= 500113
+ @${REINPLACE_CMD} -e 's/elf_i386/elf_i386_fbsd/g' \
+ ${SRCDIR}/gcc/config/i386/freebsd.h
+.endif
pre-build:
cd ${SRCDIR} ; contrib/gcc_update --touch