summaryrefslogtreecommitdiff
path: root/lang/gcc28/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1998-03-04 09:19:23 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1998-03-04 09:19:23 +0000
commitd44b822911c633a5d36b2e6926051eaca8f7ad94 (patch)
treeae2085f70441bf5aae13d58f9e46d476ce3fc4e8 /lang/gcc28/Makefile
parentUnbreak this port. (diff)
Build the gcc28 we install with itself rather than /usr/bin/cc.
Renamed manpages to <binanary>28.1.gz to reduce namespace conflicts. Added bin/gcc28 and bin/g++28.
Diffstat (limited to 'lang/gcc28/Makefile')
-rw-r--r--lang/gcc28/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/gcc28/Makefile b/lang/gcc28/Makefile
index c4427e22284c..4f925af2a1c4 100644
--- a/lang/gcc28/Makefile
+++ b/lang/gcc28/Makefile
@@ -4,7 +4,7 @@
# Date created: 17 Jan 1998
# Whom: David O'Brien <obrien@NUXI.com>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/01/16 10:15:13 obrien Exp $
#
DISTNAME= gcc-2.8.0
@@ -16,7 +16,8 @@ MAINTAINER= obrien@FreeBSD.org
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS= i386-unknown-freebsd
-MAN1= cccp.1 g++.1 gcc.1
+ALL_TARGET= bootstrap
+MAN1= cccp28.1 g++28.1 gcc28.1
post-install:
@${RM} -f ${PREFIX}/bin/c++
@@ -29,5 +30,10 @@ post-install:
${PREFIX}/lib/gcc-lib/i386-unknown-freebsd/2.8.0/cpp ; \
do strip $$prog ; \
done)
+ ln -f ${PREFIX}/bin/gcc ${PREFIX}/bin/gcc28
+ ln -f ${PREFIX}/bin/g++ ${PREFIX}/bin/g++28
+ ${MV} ${PREFIX}/man/man1/cccp.1 ${PREFIX}/man/man1/cccp28.1
+ ${MV} ${PREFIX}/man/man1/g++.1 ${PREFIX}/man/man1/g++28.1
+ ${MV} ${PREFIX}/man/man1/gcc.1 ${PREFIX}/man/man1/gcc28.1
.include <bsd.port.mk>