summaryrefslogtreecommitdiff
path: root/lang/gcc28/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-11-15 01:33:03 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-11-15 01:33:03 +0000
commit98392b87cf99174cce62afcba7a93259bd2ed9ca (patch)
tree4df356351479241b1b06fbc78f990986606f7903 /lang/gcc28/Makefile
parent- Update to 0.31.1 (diff)
Don't install compiler binaries without a version in the file name.
Diffstat (limited to 'lang/gcc28/Makefile')
-rw-r--r--lang/gcc28/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/gcc28/Makefile b/lang/gcc28/Makefile
index ffeb98dad4fc..eee04c845a34 100644
--- a/lang/gcc28/Makefile
+++ b/lang/gcc28/Makefile
@@ -37,6 +37,7 @@ CONFIGURE_TARGET= ${ARCH}-portbld-freebsdaout${OSREL}
PLIST_SUB= GNUHOST=${CONFIGURE_TARGET}
CONFIGURE_ARGS= --with-gxx-include-dir=${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/2.8.1/include/g++
+CONFIGURE_ARGS+= --program-suffix=28
GNU_CONFIGURE= yes
USE_GMAKE= yes
ALL_TARGET= bootstrap
@@ -74,8 +75,9 @@ post-install:
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/2.8.1/cpp ; \
do ${STRIP_CMD} $$prog ; \
done)
- ${LN} -f ${PREFIX}/bin/gcc ${PREFIX}/bin/gcc28
- ${LN} -f ${PREFIX}/bin/g++ ${PREFIX}/bin/g++28
+ @${MV} ${PREFIX}/bin/gcc ${PREFIX}/bin/gcc28
+ @${MV} ${PREFIX}/bin/g++ ${PREFIX}/bin/g++28
+ @${MV} ${PREFIX}/bin/gcov ${PREFIX}/bin/gcov28
@${MV} ${PREFIX}/man/man1/cccp.1 ${PREFIX}/man/man1/cccp28.1
@${MV} ${PREFIX}/man/man1/g++.1 ${PREFIX}/man/man1/g++28.1
@${MV} ${PREFIX}/man/man1/gcc.1 ${PREFIX}/man/man1/gcc28.1