summaryrefslogtreecommitdiff
path: root/lang/gcc28/Makefile
diff options
context:
space:
mode:
authorJohn Polstra <jdp@FreeBSD.org>1998-06-30 21:10:27 +0000
committerJohn Polstra <jdp@FreeBSD.org>1998-06-30 21:10:27 +0000
commit2c8f4253cce54b05dc75f8f019138126d43ee303 (patch)
treed16532a3e848a801900828f254650620555ac3c1 /lang/gcc28/Makefile
parentFix longstanding bug with Content-Length counted in messages size (diff)
Fix this port so that it can find crt0.o in /usr/lib/aout on recent
-current systems. Fix the definition of the preprocessor symbol __FreeBSD__. It had been defined as "2=3". Implement support for weak symbols. This solves the "___error" undefined problem on -current systems. Default to -fsjlj-exceptions even for C programs. This is needed because a few modules in libgcc are built with -fexceptions turned on, and the default style of exception support causes croakage. I tried a make buildworld on a recent -current system by adding the following to /etc/make.conf: CC=/usr/local/bin/gcc28 -B/usr/local/lib/gcc-lib/i386-unknown-freebsd3.0/2.8.1/ CXX=/usr/local/bin/g++28 -B/usr/local/lib/gcc-lib/i386-unknown-freebsd3.0/2.8.1/ It got pretty far along before dying. The death occurred when building our old native libstdc++, almost certainly because of header file incompatibilities. Another obstacle for make world is that this port doesn't currently build a PIC version of libgcc (libgcc_pic.a).
Diffstat (limited to 'lang/gcc28/Makefile')
-rw-r--r--lang/gcc28/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/gcc28/Makefile b/lang/gcc28/Makefile
index 91b8cc93c907..313da1a79294 100644
--- a/lang/gcc28/Makefile
+++ b/lang/gcc28/Makefile
@@ -4,7 +4,7 @@
# Date created: 17 Jan 1998
# Whom: David O'Brien <obrien@NUXI.com>
#
-# $Id: Makefile,v 1.9 1998/06/06 04:42:31 asami Exp $
+# $Id: Makefile,v 1.10 1998/06/10 20:16:08 asami Exp $
#
DISTNAME= gcc-2.8.1
@@ -30,10 +30,10 @@ post-patch:
@(cd ${WRKSRC}/config/i386/ ; \
MAJ=`sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
${MV} freebsd.h freebsd.h.in ; \
- ${SED} -e "s:__FreeBSD__:__FreeBSD__=$${MAJ}:" freebsd.h.in \
+ ${SED} -e "s:__FreeBSD__=[0-9]*:__FreeBSD__=$${MAJ}:" freebsd.h.in \
>freebsd.h ; \
${MV} freebsd-elf.h freebsd-elf.h.in ; \
- ${SED} -e "s:__FreeBSD__:__FreeBSD__=$${MAJ}:" freebsd-elf.h.in \
+ ${SED} -e "s:__FreeBSD__=[0-9]*:__FreeBSD__=$${MAJ}:" freebsd-elf.h.in \
>freebsd-elf.h)
pre-install: