summaryrefslogtreecommitdiff
path: root/lang/fpc
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-07-29 02:48:26 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-07-29 02:48:26 +0000
commitc8f8bcdfe0eaf5dd53e7cc8a0a4ddaf5a491d63c (patch)
treeb1a92ddd05eac2a4695b80f7d29d20bd96292a9d /lang/fpc
parent- Update to 1.2.3 (diff)
- Added post-extract on Makefiles.units. It remove the svn directories from
some fpc ports. - Added PORTREVISION for each port - Fixed pkg-plist on fpc-gtk2 and fpc-gtk ports - Fixed the gtk, glib and gdk libraries linking for fpc-gtk - Removed obsolete patches from fpc-gtk. Now it's using ${REINPLACE_CMD} - Removed post-extract from fpc-fcl. I just added it to makefiles.units file Approved by: garga (mentor)
Diffstat (limited to 'lang/fpc')
-rw-r--r--lang/fpc/Makefile2
-rw-r--r--lang/fpc/Makefile.units4
2 files changed, 5 insertions, 1 deletions
diff --git a/lang/fpc/Makefile b/lang/fpc/Makefile
index d648b96e9e67..4e4042333345 100644
--- a/lang/fpc/Makefile
+++ b/lang/fpc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fpc
PORTVERSION= 2.0.2
-PORTREVISION= 1
+PORTREVISION?= 1
CATEGORIES?= lang
MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/source-${PORTVERSION}/:source \
ftp://planetmirror.com/pub/fpc/dist/source-${PORTVERSION}/:source \
diff --git a/lang/fpc/Makefile.units b/lang/fpc/Makefile.units
index 9254f4a8602d..d683f80ef3f6 100644
--- a/lang/fpc/Makefile.units
+++ b/lang/fpc/Makefile.units
@@ -15,6 +15,10 @@ DISTFILES+= ${DISTNAME:S/$/.bin/}${EXTRACT_SUFX}:bin
MAKE_ENV+= FPCMAKE=${WRKDIR}/${PORTNAME:S/$/-bin/}/bin/fpcmake
.endif
+post-extract:
+ @cd ${WRKDIR}/${WRKUNITDIR} && \
+ ${FIND} ${WRKSRC} -type d -name .svn | ${XARGS} ${RM} -rf
+
do-build:
@cd ${WRKDIR}/${WRKUNITDIR} && ${GMAKE} all ${MAKE_ENV}