summaryrefslogtreecommitdiff
path: root/lang/eperl/Makefile
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>1997-01-04 18:54:38 +0000
committerAndreas Klemm <andreas@FreeBSD.org>1997-01-04 18:54:38 +0000
commit868388af95cc7998626d5e4e42f45a4a63325b0b (patch)
tree130b27236b5163d1010a1fb497d7f339457f430c /lang/eperl/Makefile
parentThe original distribution tarball has been renamed. (diff)
eperl - new port
Embedded Perl 5 for HTML, a server-side scripting language Reviewed by: andreas Submitted by: Ralf S. Engelschall <rse@engelschall.com>
Diffstat (limited to 'lang/eperl/Makefile')
-rw-r--r--lang/eperl/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/lang/eperl/Makefile b/lang/eperl/Makefile
new file mode 100644
index 000000000000..944bef2c05dd
--- /dev/null
+++ b/lang/eperl/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: eperl
+# Version required: 2.0.2
+# Date created: Sat Jan 4 18:04:13 MET 1997
+# Whom: Ralf S. Engelschall <rse@engelschall.com>
+#
+# $Id$
+#
+
+DISTNAME= eperl-2.0.2
+CATEGORIES= www
+MASTER_SITES= http://www.engelschall.com/sw/eperl/dist/
+
+MAINTAINER= rse@engelschall.com
+
+BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5
+RUN_DEPENDS= ${PREFIX}/etc/apache/srm.conf:${PORTSDIR}/www/apache
+
+GNU_CONFIGURE= yes
+
+do-install:
+ @if [ ! -d ${PREFIX}/www/cgi-bin ]; then \
+ ${MKDIR} ${PREFIX}/www/cgi-bin; \
+ fi
+ cd ${WRKSRC}; ${INSTALL_PROGRAM} nph-eperl ${PREFIX}/www/cgi-bin/
+ @if [ ".`grep ePerl ${PREFIX}/etc/apache/srm.conf`" = . ]; then \
+ echo "Adding glue config to ${PREFIX}/etc/apache/srm.conf."; \
+ echo "" >>${PREFIX}/etc/apache/srm.conf; \
+ echo "# ePerl -- Embedded Perl 5 for HTML (server-side scripting language)" >>${PREFIX}/etc/apache/srm.conf; \
+ echo "AddType application/x-httpd-eperl .phtml .eperl .epl" >>${PREFIX}/etc/apache/srm.conf; \
+ echo "Action application/x-httpd-eperl /cgi-bin/nph-eperl" >>${PREFIX}/etc/apache/srm.conf; \
+ echo "" >>${PREFIX}/etc/apache/srm.conf; \
+ fi
+
+.include <bsd.port.mk>