summaryrefslogtreecommitdiff
path: root/lang/ccscript/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-10-14 12:05:42 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-10-14 12:05:42 +0000
commitf3cbaa1a808778c1445e2c09deddd25e0030bbba (patch)
treea36063a8d50e49600cdaf69c65049cf66e8bf740 /lang/ccscript/Makefile
parentUpdate to 6.4.1 (diff)
Fix breakage of ccscript on 4.x by lifting requisite commoncpp to gcc 3.4
(and track this for ccaudio which also uses commoncpp)
Diffstat (limited to '')
-rw-r--r--lang/ccscript/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/lang/ccscript/Makefile b/lang/ccscript/Makefile
index 21d50e0c359f..53713abbeb9c 100644
--- a/lang/ccscript/Makefile
+++ b/lang/ccscript/Makefile
@@ -18,7 +18,8 @@ COMMENT= State-event driven class extendible C++ script interpreter
LIB_DEPENDS= ccgnu2-1.3.1:${PORTSDIR}/devel/commoncpp
USE_GNOME= gnometarget
-USE_LIBTOOL_VER= 15
+USE_INC_LIBTOOL_VER= 15
+USE_GCC= 3.4
INSTALL_TARGET= install man
INSTALLS_SHLIB= yes
@@ -32,4 +33,7 @@ MAN3= ScriptCommand.3cc ScriptImage.3cc ScriptInterp.3cc \
CFLAGS+= -fPIC
.endif
+pre-configure:
+ @${CP} ${LTMAIN} ${WRKSRC}/config
+
.include <bsd.port.post.mk>